Firefox 15 does not always load my home page when it starts up.

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: greta_watson, Unassigned)

Tracking

15 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120911180149

Steps to reproduce:

Started my computer.  Clicked on the Firefox icon to start Firefox.  My preferences include loading my home page (an html file on my computer) when Firefox starts.  I have also set browser.newtab.url to the same thing.


Actual results:

Some of the time, a blank page shows where my home page should show.


Expected results:

My home page should have loaded.

If I click on "new tab", the new tab always seems to load my home page properly.  It is only when I first start up Firefox that this problem may occur.

Since this is an intermittent problem, and there is a work-around (clicking on the "home" icon), this is undoubtedly a low-priority bug.

Comment 1

6 years ago
Did you try with a new profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
(Reporter)

Comment 2

6 years ago
(In reply to Loic from comment #1)
> Did you try with a new profile?
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

Yes, I did.  This weekend, I did a fresh install of Fedora 17, and manually changed the Firefox preferences.  Firefox still opens sometimes with a blank screen.

Updated

6 years ago
Component: Untriaged → General
Hi, Your issue is a support request, but Bugzilla is not equipped to handle these kind of requests. We took the liberty to copy your issue over to our support platform, where we can help you solve your problem. In the next few minutes you'll receive an email that an account on support.mozilla.org was created. You just need to click the confirmation link, and your support request will be made live.

If you wish to log-in to leave additional information, please use this link to request a new password: https://support.mozilla.org/users/pwreset

We'll close this bug at this point, please continue the discussion on support.mozilla.org

Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

6 years ago
I disagree with the staus that it's invalid.  Maybe resolved won't fix, but not invalid.  Intermittent bugs are still bugs.  I tried the following as well:  exported my bookmarks, which are extensive, to bookmarks.html.  Then created a new profile, removed the bookmarkbackups folder and the places.sqlite folder, put the bookmarks.html folder in the new directory and opened Firefox.  I did this because opening Firefox and then importing the bookmarks creates a whole new hierarchy that has to be moved around extensively to get it to where it was before.

Anyway, most of the time, my home page loads properly.  On occasion, it does not.  When it does not, it is using the same set of bookmarks and other setting as it uses when it loads properly.  It is more likely to load improperly when I've just logged in using the KDE feature of reloading a saved session.  However, sometimes when I start Firefox during a KDE session, it loads a blank page instead of my home page.
(Reporter)

Comment 5

6 years ago
Actually, this is a regression.  This behavior was not happening in previous versions of Firefox, which I had been using with the same settings and bookmarks.
(Reporter)

Comment 6

6 years ago
It does occur in Firefox 12 run under Fedora 17.  Before I upgraded to Fedora 17, it did not ever happen.  But I'm not about to revert to Fedora 16 to see when it started.  My experience says this problem could be either an uninitialized variable or a race condition.  The support.mozilla.org is less than helpful so far.
You need to log in before you can comment on or make changes to this bug.