Closed Bug 793621 Opened 10 years ago Closed 10 years ago

The proxy box shows itself in a never ending loop with serverfault.com

Categories

(Core :: Networking: WebSockets, defect)

15 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 766817

People

(Reporter: nicolas.michel, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

I installed firefox 15.0 on ArchLinux with XFCE desktop. I'm at work and behind a proxy web server which is configured with an "automatic proxy configuration URL".

Then go to serverfault.com or stackoverflow.com


Actual results:

The proxy dialog box is showing asking for the user/password (credentials that are already saved) in a never ending loop (I click on OK then the box shows itself again after 1 or 2 seconds).
Firefox is then unusable since even other tabs are freezed because of the intrusive proxy box that keeps the focus on it and come back forever.

The only workaround is to close serverfault.com or stackoverflow.com (being really fast with alt-f4 to close the proxy box and ctrl-w to close the tab) and open another web browser like Google Chrome where it works pretty well...

I have the same problem on Windows 7! So it is not related to linux.


Expected results:

- firstly: the proxy box should not be application-wide but tab-wide (but saved credentials in a tab should be saved and use for other tabs like it is already). So it wont get the focus if it's triggered by a tab that is not currently active.
- secondly: that box shouldn't comes as often. I don't really know why the box is showing in a neverending loop but I feel this is because firefox doesn't make a difference between an authentication error against the proxy server (wrong user or password) and a failed connexion for another reason. So it asks for credentials. Here are tshark dumps when clicking on OK of the proxy box (we see in tshark that message coming from the proxy: WebSocket 1478 WebSocket Unknown Opcode)

35.185353 192.168.253.128 -> 153.89.254.3 TCP 54 60821 > 8080 [FIN, ACK] Seq=874 Ack=1426 Win=17088 Len=0
 35.185760 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60821 [ACK] Seq=1426 Ack=875 Win=64239 Len=0
 35.186635 192.168.253.128 -> 153.89.254.3 TCP 54 60822 > 8080 [FIN, ACK] Seq=845 Ack=1426 Win=17088 Len=0
 35.187007 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60822 [ACK] Seq=1426 Ack=846 Win=64239 Len=0
 35.189603 192.168.253.128 -> 153.89.254.3 TCP 74 60823 > 8080 [SYN] Seq=0 Win=14600 Len=0 MSS=1460 SACK_PERM=1 TSval=1492674 TSecr=0 WS=128
 35.189825 192.168.253.128 -> 153.89.254.3 TCP 74 60824 > 8080 [SYN] Seq=0 Win=14600 Len=0 MSS=1460 SACK_PERM=1 TSval=1492674 TSecr=0 WS=128
 35.190918 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60823 [SYN, ACK] Seq=0 Ack=1 Win=64240 Len=0 MSS=1460
 35.190944 192.168.253.128 -> 153.89.254.3 TCP 54 60823 > 8080 [ACK] Seq=1 Ack=1 Win=14600 Len=0
 35.190984 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60824 [SYN, ACK] Seq=0 Ack=1 Win=64240 Len=0 MSS=1460
 35.190991 192.168.253.128 -> 153.89.254.3 TCP 54 60824 > 8080 [ACK] Seq=1 Ack=1 Win=14600 Len=0
 35.191122 192.168.253.128 -> 153.89.254.3 HTTP 956 GET / HTTP/1.1 
 35.191305 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60823 [ACK] Seq=1 Ack=903 Win=64240 Len=0
 35.191367 192.168.253.128 -> 153.89.254.3 HTTP 927 GET / HTTP/1.1 
 35.191477 153.89.254.3 -> 192.168.253.128 TCP 60 8080 > 60824 [ACK] Seq=1 Ack=874 Win=64240 Len=0
 35.195210 153.89.254.3 -> 192.168.253.128 WebSocket 1478 WebSocket Unknown Opcode  
 35.195238 192.168.253.128 -> 153.89.254.3 TCP 54 60823 > 8080 [ACK] Seq=903 Ack=1426 Win=17088 Len=0
 35.196462 153.89.254.3 -> 192.168.253.128 WebSocket 1478 WebSocket Unknown Opcode  
 35.196526 192.168.253.128 -> 153.89.254.3 TCP 54 60824 > 8080 [ACK] Seq=874 Ack=1426 Win=17088 Len=0
OS: Windows 7 → All
I found a confirmation of this bug on the Bluecaot Knowledge Base :
https://kb.bluecoat.com/index?page=content&id=KB5274&actp=RSS
Component: Untriaged → Networking: WebSockets
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766817
You need to log in before you can comment on or make changes to this bug.