unable to move the embedded Google map on some websites (flightradar24.com, targeo.pl...)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: mathieu.marquer, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox18-)

Details

(Whiteboard: [mozTouchEvent], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120923030601

Steps to reproduce:

Going on flightradar24.com


Actual results:

I'm unable to move/zoom the map


Expected results:

Being able to move/zoom it. Did work before (a few days ago). Works with Google Chrome.

Comment 1

6 years ago
Regression window(m-c)
Good(except Bug 793132)
http://hg.mozilla.org/mozilla-central/rev/b461a7cd250e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120922052915
Bad:
http://hg.mozilla.org/mozilla-central/rev/9d285bedbc1f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120922154714
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b461a7cd250e&tochange=9d285bedbc1f


Regression window(m-i)
Good(except Bug 793132)
http://hg.mozilla.org/integration/mozilla-inbound/rev/8d077e0638d4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120922122715
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/fcf9991c8d97
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120922122915
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8d077e0638d4&tochange=fcf9991c8d97
Suspected : Bug 726615
Blocks: 726615
Status: UNCONFIRMED → NEW
tracking-firefox18: --- → ?
Component: Untriaged → Widget: Win32
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Duplicate of this bug: 794375

Updated

6 years ago
Component: Widget: Win32 → DOM

Updated

6 years ago
tracking-firefox18: ? → +
Also a problem on the maps at trulia.com

Comment 4

6 years ago
Created attachment 670497 [details]
testcase based on Google Maps (Javascript API v3)

Updated

6 years ago
Keywords: testcase
Version: 18 Branch → Trunk

Comment 5

6 years ago
Same issue on targeo.pl
(Reporter)

Updated

6 years ago
Summary: flightradar24.com : unable to move the Google map → unable to move the embedded Google map on some websites (flightradar24.com, targeo.pl...)
So, is this an evangelism issue?  Or do we need a code fix?
Um to Jim, but given the number of regressions from bug 726615 I suspect the latter.

Comment 8

6 years ago
This is our problem, at least partially. We should not enable touch events in case the
device doesn't support them.

Comment 9

6 years ago
Possible fixes are being discussed in Bug 798821.

Updated

6 years ago
Depends on: 798821

Updated

6 years ago
No longer depends on: 798821

Updated

6 years ago
No longer blocks: 726615

Updated

6 years ago
Depends on: 806805

Updated

6 years ago
tracking-firefox18: + → -
Whiteboard: [mozTouchEvent]
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Blocks: 806805
No longer depends on: 806805
You need to log in before you can comment on or make changes to this bug.