Save Image As is ignoring Content-Disposition filename=

RESOLVED DUPLICATE of bug 789909

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 789909
6 years ago
6 years ago

People

(Reporter: khuey, Unassigned)

Tracking

({regression})

unspecified
regression
Points:
---

Firefox Tracking Flags

(firefox17 unaffected, firefox18- unaffected)

Details

Visit http://desmond.imageshack.us/Himg24/scaled.php?server=24&filename=missionbay141.jpg&res=landing

Right click on the image and choose Save Image As.

Nightly suggests scaled.php for the filename, while Aurora and Chrome suggest missionbay141.jpg.

The HTTP headers for this response include 'Content-Disposition:inline; filename=missionbay141.jpg', so missionbay141.jpg is the correct filename to suggest.

I suspect this is a regression from Bug 254139.
WFM in today's Mac Nightly.
Yeah, WFM on Windows too.  Didn't work on the 9/18 build though!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 789909

Updated

6 years ago
status-firefox18: affected → unaffected
tracking-firefox18: ? → -
You need to log in before you can comment on or make changes to this bug.