Closed Bug 793690 Opened 7 years ago Closed 7 years ago

background: radial-gradient does not repaint properly when close dialog box or maximize browser window

Categories

(Core :: Graphics, defect)

18 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox18 + fixed

People

(Reporter: alice0775, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached file sample html
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/9d285bedbc1f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120923030601

Steps to reproduce:
1. Open attached
2. Open dialog window such as Ctrl+Shift+Del or Ctrl+Shift+B
3. Close the dialog window

OR

Steps to reproduce:
1. Open attached
2. Shrink browser window size
3. Maximize the browser window

Actual results:
 Background broken


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/80499f04e875
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120918235157
Bad:
http://hg.mozilla.org/mozilla-central/rev/0c8ac138706e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120919071856
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80499f04e875&tochange=0c8ac138706e


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/be731f9147dc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120918155756
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c0a341f7b0c9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120918160557
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=be731f9147dc&tochange=c0a341f7b0c9

Triggered by:Bug 772726
Works for me. Possibly this is fixed by patch in bug 787947.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #1)
> Works for me. Possibly this is fixed by patch in bug 787947.

Please try windows7 classic.

In Windows7 Aero, it is different and strange behavior, The background is displayed in thin horizontal strip-shaped.
And click the  strip, background is expanded...
Attached image Screen shot
*Nightly18.a1: comparison between Windows7Aero and Classic, and after shown Dialog
(In reply to Alice0775 White from comment #3)
err
s/And click/And double click/
Bas, I'm pretty sure this is "Patch for the D2D clipping issue" from bug 772726. My testcase is just
<html style="background: radial-gradient(circle, black 50px, black 300px) repeat">

I get the funny black strip Alice refers to. Because the inside circle has nonzero radius, we take the radial gradient path in DrawTargetD2D::FinalizeRTForOperation and I'm pretty sure that is causing problems with that patch.
Assignee: nobody → bas.schouten
Attached patch fixSplinter Review
I tried to write a reftest for this but it's rather hard.
Assignee: bas.schouten → roc
Attachment #664812 - Flags: review?(bas.schouten)
Comment on attachment 664812 [details] [diff] [review]
fix

Review of attachment 664812 [details] [diff] [review]:
-----------------------------------------------------------------

It's a miracle this ever worked half-decent... I guess we almost always push a nice pixel aligned rectangular clip the size of the surface.
Attachment #664812 - Flags: review?(bas.schouten) → review+
https://hg.mozilla.org/mozilla-central/rev/8a788d3eccd1

Should this have a test?
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
I couldn't reproduce the issue using the STR from the description. The background stays the same on my machine.

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120917030530

Any suggestions?
QA Contact: manuela.muntean
You need to log in before you can comment on or make changes to this bug.