If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Geolocation broken on B2G/otoro

RESOLVED DUPLICATE of bug 779455

Status

()

Core
Geolocation
RESOLVED DUPLICATE of bug 779455
5 years ago
5 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
I'm testing Geolocation on my otoro quite often by installing my Lantea Maps app from the Marketplace, and it worked some time in the week before MozCamp EU but broke later that week and didn't go back to working since.

It asks for the permission but then never gets a position even though the icon for Geolocation turns up in the status bar.

I just tried in a Linux desktop build and I do get something there, apparently, so it might be only on devices. Yesterday, someone in the B2G channel said it's not working on his Nexus S (IIRC) as well.

Comment 1

5 years ago
The otoro doesn't have wifi or ip --> geolocation.  it only has a gps receiver.  Are you outside w/ a clear view of the sky when using this Lantea Maps application?
I believe this is a dup of bug 779455. If I'm wrong, reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779455
Marking a blocker in case this was ever un-duped.
blocking-basecamp: ? → +
(Reporter)

Comment 4

5 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> I believe this is a dup of bug 779455.

Looks like it, thanks.

(In reply to Doug Turner (:dougt) from comment #1)
> The otoro doesn't have wifi or ip --> geolocation.  it only has a gps
> receiver.

I know that, yes.

>  Are you outside w/ a clear view of the sky when using this Lantea
> Maps application?

I've tried it in numerous settings, including ones where other devices I have that also only have GPS available (N900 without a SIM card or wifi connection, not that the latter would help it) would actually get a GPS fix after some time.
Of course, on devices like the N900 I at least see some data that the GPS is active even before it has a fix (i.e. details on satellites it's seeing) which we don't have a web API for and therefore can't see on the otoro.

As I said, it *has* been working some time ago, but it's doesn't in recent weeks.
You need to log in before you can comment on or make changes to this bug.