Closed Bug 793771 Opened 8 years ago Closed 7 years ago

Use drawing cache on the tabs pane sliding on pre-ICS phone

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 19

People

(Reporter: lucasr, Assigned: lucasr)

Details

(Whiteboard: ui-responsiveness)

Attachments

(1 file)

We can't use drawing cache on the SurfaceView but we should be able to use drawing cache on the chrome bits.
OS: Linux → Android
Hardware: x86 → All
Whiteboard: ui-responsiveness
Attachment #671412 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/1a3fae956dd7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Comment on attachment 671412 [details] [diff] [review]
Use drawing cache on the tabs pane sliding on pre-ICS phone

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: Significantly improves the tabs tray animation performance on pre-ICS devices. Part of the batch of improvements in the tabs UX started in bug 767980.
Testing completed (on m-c, etc.): It's been a few weeks in m-c now, no issues found.
Risk to taking this patch (and alternatives if risky): Low, well tested in m-c
String or UUID changes made by this patch: none
Attachment #671412 - Flags: approval-mozilla-aurora?
Comment on attachment 671412 [details] [diff] [review]
Use drawing cache on the tabs pane sliding on pre-ICS phone

As discussed offline with Lucas and Release Management team, we will have the enitire tab UX improvements ride the trains.
Attachment #671412 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
You need to log in before you can comment on or make changes to this bug.