Screen orientation in a Twitter web app is always locked to portrait-primary

VERIFIED WORKSFORME

Status

()

Firefox for Android
Web Apps
P2
normal
VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

18 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps:

1. Install and launch a web app with no orientation property specified
2. Rotate the device into each orientation

Expected:

Upon changing the orientation, the page should re-render to that specific orientation.

Actual:

Nothing changes. The orientation appears to be locked on portrait-primary.
(Reporter)

Updated

6 years ago
Priority: -- → P2
Can't reproduce this on a Nexus 7 (JB) or my DroidX (GB). I assume this was on a Galaxy Nexus? I can try one later tonight, but can you double check this Jason?
(Reporter)

Comment 2

6 years ago
(In reply to Wesley Johnston (:wesj) from comment #1)
> Can't reproduce this on a Nexus 7 (JB) or my DroidX (GB). I assume this was
> on a Galaxy Nexus? I can try one later tonight, but can you double check
> this Jason?

Yeah, I tested this on a Galaxy Nexus running Android 4.04. I can still reproduce this.
Is there a particular app you're testing with? I have tried Lanyard and the Market.
(Reporter)

Comment 4

6 years ago
(In reply to Wesley Johnston (:wesj) from comment #3)
> Is there a particular app you're testing with? I have tried Lanyard and the
> Market.

I was testing with Twitter. The bug does not reproduce with the marketplace though. Why is it only happening with Twitter?
(Reporter)

Comment 5

6 years ago
(In reply to Jason Smith [:jsmith] from comment #4)
> (In reply to Wesley Johnston (:wesj) from comment #3)
> > Is there a particular app you're testing with? I have tried Lanyard and the
> > Market.
> 
> I was testing with Twitter. The bug does not reproduce with the marketplace
> though. Why is it only happening with Twitter?

Strange. So twitter in the FF Android browser allows the orientation changes when I change the orientation of the device, but the webapp does not seem to allow the orientation change.
Summary: Screen orientation in a web app is always locked to portrait-primary → Screen orientation in a Twitter web app is always locked to portrait-primary
Hmm... not sure either. Twitter works for me as well. Will try on a GN.
(Reporter)

Comment 7

6 years ago
Tried on a different phone - I can't reproduce on Twitter. What likely happened here is I got my phone into a bad state then. Not sure of the how though right now. For right now, I'm going to close this as worksforme, but I'll keep a look out for the bad state situation.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 8

6 years ago
Build ID: 19.0 (2012-10-17) Nightly Channel
Device: Samsung Galaxy Nexus / Galaxy Note
OS: Android 4.1/  4.0.4

The Twitter Web App behaves as expected at rotation. Setting the bug to Verified WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.