Thunderbird 15 default theme errors

RESOLVED INVALID

Status

Thunderbird
Theme
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: Jaak Ristioja, Unassigned)

Tracking

15 Branch
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 664157 [details]
Screenshot using Clearlooks Gtk2 theme

The default thunderbird theme renders some ugly stuff (see screenshot).
(Reporter)

Comment 1

5 years ago
Created attachment 664159 [details]
Screenshot using QtCurve Gtk2 theme
(Reporter)

Updated

5 years ago
Attachment #664157 - Attachment description: Screenshot using Clearlooks theme → Screenshot using Clearlooks Gtk2 theme
I'm not seeing this with Clearlooks under Mint. Are you also using Firefox? If yes, can you check the Add-ons manager. Does he have also the white strip in the header area (this strip is in both of your themes white)? Can you reset the Linux theme colors?
If all doesn't help, could try TB with a new profile?
(Reporter)

Comment 3

5 years ago
Created attachment 664378 [details]
Screenshot using new profile with QtCurve GTK2 theme

There have been no white strips in Firefox.

It appears that using a new profile the white artifacts are no longer there. There still appear to be some color contrast glitches with using system background+TB foreground or system foreground+TB background colors, e.g. rendering black text on dark background (TB foreground color, system background color).

I'd still consider this an improvement. How would one fix an existing Thunderbird profile?

Switching system theme colors would not be a solution for this bug, but only a possible workaround. I guess it could improve the looks regarding this bug, but I'm really against changing them permanently. I like my colors (dark background, light foreground).
I am unable to reproduce this bug with Clearlooks too, and I've never seen it before (been using clearlooks with the same profile for quite some time now). Maybe some cache issue?

Comment 5

3 years ago
Hello.

This is a cache bug. We will be looking forward to fixing this. Thanks for the report.



Thanks,
Ryan Weaber

Comment 6

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
tracking-thunderbird31: --- → ?
tracking-thunderbird_esr31: --- → ?

Comment 7

3 years ago
Comment on attachment 664157 [details]
Screenshot using Clearlooks Gtk2 theme

What system are you using? Ubuntu? Kubuntu? Windows? Mac? This will help us fix the bug.
Flags: needinfo?(jaak)

Updated

3 years ago
Flags: needinfo?(jaak)
(Reporter)

Comment 8

3 years ago
Issue still present in Thunderbird 31 running on Gentoo Linux (x86_64) with KDE 4.13.3.
I still can't reproduce your issue with Ubuntu and KDE 4.13.3. In comment 3 you wrote with a new profile the issue is gone. If this is still the case please can you try, when TB is closed, to rename localstore.rdf and start TB again?
blocking-b2g: 2.1? → ---
tracking-thunderbird31: ? → ---
tracking-thunderbird_esr31: ? → ---
(Reporter)

Comment 10

3 years ago
(In reply to Richard Marti (:Paenglab) from comment #9)
> I still can't reproduce your issue with Ubuntu and KDE 4.13.3. In comment 3
> you wrote with a new profile the issue is gone. If this is still the case
> please can you try, when TB is closed, to rename localstore.rdf and start TB
> again?

Deleting localstore.rdf did not help. However new empty profiles do not have the issue.
Then it must be a profile issue.

I'm not sure but I think I've seen KDE had added some rules to userChrome.css which are maybe outdated with the new tabs. I deleted them a long time ago and I don't know more what they are for. Please can you check in your profile in chrome/userChrome.css if there are some rules from KDE? For a quick check you can also rename this file and start TB again. You can also attach this file here, then we can check it.
Flags: needinfo?(jaak)
(Reporter)

Comment 12

3 years ago
The culprit was the first line

   * { color: #000; background: #fff; }

in chrome/userContent.css without any comments attached. There were also lines by KDE chrome/userContent.css and lines by QtCurve in chrome/userChrome.css, but these are currently no problem. Maybe some random add-on leftover from the past?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jaak)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.