PDF Controls don't function in Nightly

RESOLVED WORKSFORME

Status

()

Firefox
PDF Viewer
P3
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: steamcarriage@netscape.net, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-ux])

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
When I call up a PDF document in Nightly 64-bit 18.0a1 for the past couple of days, I can't do anything with the controls at the upper right of the screen - most importantly being able to print.  The functions are just dead - no response at all.  I'm running Win7-64 bit on an Intel processor -- all up to date.  This used to work fine up until early last week.  I figured it might be a single day or two but it has continued.  I have to revert to Firefox 32-bit to print any PDF documents. I see there are other similar complaints so this may be another symptom of the root problem.

Comment 2

5 years ago
Strange, I can't reproduce on either 64 or 32 bit Nightly on Windows 7.

The download button is currently broken (see Bug 793659), but print, fullscreen and the current view button all work for me.
Can you try updating your version of nightly and retest since this should be fixed?
Priority: -- → P3
Whiteboard: [pdfjs-c-ux]
(Reporter)

Comment 4

5 years ago
The other buttons seem to work now with a minor exception.  When I am viewing a PDF, the file extension is made .aspx and not .pdf.  Before the downloaded PDF file would get the proper .pdf extension and not the .aspx extension.  So, yes, I can now save PDFs, but they are with the wrong extension and not able to be opened later in the Adobe PDF viewer.

Comment 5

5 years ago
I still can't reproduce on 64bit Nightly on Windows 7...

Does this happen for every pdf you choose to save? Have you tried with a clean profile, and does it still happen?
(Reporter)

Comment 6

5 years ago
I'm not sure I know what you mean by "clean profile".  Just to recap - I'm using Windows 7 - 64 bit (no problem in 32-bit).  Its an Intel i7-970, 3.2 GHz 6 core dual threading processor.  It is Nightly 18.a.1 - today's update. Nightly clears the cache, history, etc (all but passwords) when I close it.  It opened fresh for the testing I did based on your post.  

The Full Screen button works however once the PDF is in full screen, I can only see one page - no scrolling between pages.  When I use the print button, I do not get all the pages to print - some are blank others are printed.  When I save, and don't accept the default name I have to put the PDF extension on them (I didn't used to have to do this - it automatically added .pdf.  If I leave the filename with no extension when renaming it comes up .aspx which I can later change to .pdf and the file opens fine in the PDF viewer.  So that is what I'm experiencing as of writing this reply.

Comment 7

5 years ago
This page explains about profiles and how to create a new, clean one https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

You might also want to reset Firefox as described at https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems

If this is no longer a problem, kindly change the status to RESOLVED WORKSFORME at https://bugzilla.mozilla.org/show_bug.cgi?id=793832

If this is still a problem, kindly provide the URL of the problematic PDF file.
Flags: needinfo?(steamcarriage)

Comment 8

5 years ago
I understand what you mean better now. 

Fullscreen currently only allows you to scroll between pages using the left/right arrow keys. Whether or not this is intended as final, I'm not sure (see Bug 795228)

Print doesn't really work at all by any reasonable measure right now (https://github.com/mozilla/pdf.js/issues/154 , Bug 752390)

The reported download behavior is quite interesting though, as for me it just downloads without prompting to the default folder. There's definitely some weird stuff going on there.
(Reporter)

Comment 9

5 years ago
Cleaning the profile and resetting the profile doesn't correct this.  I can say that whatever you've done has improved the situation as when I reported it downloading wasn't possible at all.  This morning a new twist turned up.

The files that I've experienced this with are investment and financial in nature.  It is the end of month and my financial institutions provide monthly reports and account summaries in PDF formats for download.  Please excuse me for not sharing the links to those.  As soon as I download something that is not financially sensitive, I'll share the URL.

The new twist that happened today was that I have multiple accounts with an investment firm (savings account, IRA, checking, etc).  At the end of the month all the statements are on a page and by clicking the line, the statement opens in a new window as a PDF. I then can download it, print it, etc.  Well the first one of the list downloads fine (I supplied the filename, no extension, and it downloaded as a PDF but with the .aspx extension which I could change to .pdf and could open the saved version in the Adobe PDF viewer).  

However, when I closed the window of the current statement and clicked on the 2nd statement, nothing happened.  It should have opened up in a new window.  I finally logged out, closed Nightly, restarted Nightly, relogged in, and when I clicked on the 2nd account's statement it opened in the new window as expected.  This time I supplied the filename and .pdf extension and it saved as such and I could open it with Adobe viewer.  Closed the window and clicked on the 3rd account for its statement and nothing again.  In fact I noticed I couldn't open the one I had just opened.  

Frustrated I logged out and went over to the 32-bit FireFox were things worked as expected and without any issues.  Whatever is causing this, my uneducated guess is it is how PDFs are handled in the 32 and 64 bit versions.  The windows look entirely different.  In the 32-bit version there is a controls window that pops up for printing, downloading, etc.  For the 64-bit version its in a menu bar at the top.  I notice the 32-bit Firefox version's look as far as text, pictures, etc appear identical to what I see on the Adobe Acrobat Pro X viewer.  However that is changed for the 64-bit version with Nightly.  I don't know if the two browsers use different PDF viewers or what.

One thing may be of help.  I can go to a website in Firefox 32 and open a PDF and it shows up in the browser window.  If I go to the exact same site using Nightly 64, when the PDF opens in the browser window, I get a yellow caution bar at the to which reads "This PDF document might not be displayed correctly." with a button that allows me to "Open With A Different Viewer".  Note that if I click the button, it wants to save the PDF document.  That all seems weird to me.  If you want to see an example of this behavior then go to www.aquaticlife.com.  Click on the "see more" button for one of the products that goes past and in the window that subsequently opens click Specs/User Manuals.  Click the "view" button for either the user manual or spec sheet.  For me the PDF that opens has the above caution showing at the top.  Unfortunately the for my initial complaint, this is a file that will save with a .pdf extension if when I create a new filename and don't apply an extension.

I don't know what else I can tell you.  As David has suggested, there's something weird going on here.  Nightly is not working like Firefox.  Its better than it was a week ago when downloads just didn't happen, but its still not working the same with all documents.
Flags: needinfo?(steamcarriage)
(Reporter)

Comment 10

5 years ago
Just had another flaky event.  When a PDF opened in Nightly, the 4 buttons for printing, downloading, etc briefly appear and then disappear.  When I move the pointer over them the reappear and I can click them.  No change in how they work.  It is that they used to come up and stay there.  Now they show briefly and disappear but appear if I run the curser over them and they will function.  Thought I'd add this in case it is any help.
(Reporter)

Comment 11

5 years ago
As of today, the problem appears to have been corrected so I will mark it off as resolved.  The PDFs are now downloading and with the PDF extension.  It would be nice if the Zoom settings in the middle of the page could be set at default.  Its not a bug but it would be good if I could set the default zoom percentage and have all future documents open up in that mode and not default to "automatic" as it does now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.