The default bug view has changed. See this FAQ.

Feed body views AppMenu items are not working anymore ( [ ≡ ] > View > Feed Message Body As > Web Page | Summary | Default Format)

RESOLVED FIXED in Thunderbird 18.0

Status

Thunderbird
Message Reader UI
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

(Blocks: 1 bug)

unspecified
Thunderbird 18.0
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

5 years ago
Bug 596234 changed on main menu items the oncommand from ChangeFeedShowSummaryPref() to FeedMessageHandler.onSelectPref = but forgot the AppMenu items. The AppMenu items are also not showing the checked mode.
(Assignee)

Comment 1

5 years ago
Created attachment 664200 [details] [diff] [review]
patch

This patch fixes the issues. But when I change the view with the AppMenu items the checked state on main menu isn't updated when this isn't opened before I change the view. It looks like the main menu items aren't initialized correctly.

Mike, do you have a solution for this problem?
Attachment #664200 - Flags: feedback?(mconley)
Investigating...
Paenglab:

Hm - I can't seem to reproduce the problem - the View > Feed Message Body As items in the main menu seem to change properly when I update them from the AppMenu.

If you can reproduce it reliably, can you give me detailed STR?

-Mike
(Assignee)

Comment 4

5 years ago
STR:
- Feed Message Body has to be set on Summary.
- Close TB.
- Open TB, select a feed message.
- Change in AppMenu the view from Summary to 'Web Page'.
- Open the main menu and go to View/'Feed Message Body'. Summary is still checked.
- Move in View menu to Headers and let open the submenu.
- Move back to 'Feed Message Body'. 'Web Page' is selected.

This also works from 'Default Format' to the two other options.
Excellent - thanks, reproduced.
Created attachment 664631 [details] [diff] [review]
Patch v1

Wow, that was a lot harder to figure out than I expected.

Basically, I think we've hit a XUL bug here. I think we're experiencing a bug with menuitem's autocheck feature when type="radio".

Unchecking the other menuitems seems to fix it. Let's roll with that.
Comment on attachment 664200 [details] [diff] [review]
patch

See above.
Attachment #664200 - Flags: feedback?(mconley) → feedback+
(Assignee)

Comment 8

5 years ago
Created attachment 664644 [details] [diff] [review]
patch v2

Combination of mconley's and my patch.
Assignee: nobody → richard.marti
Attachment #664200 - Attachment is obsolete: true
Attachment #664631 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #664644 - Flags: review?(mkmelin+mozilla)

Comment 9

5 years ago
Comment on attachment 664644 [details] [diff] [review]
patch v2

Review of attachment 664644 [details] [diff] [review]:
-----------------------------------------------------------------

Thx Richard! r=mkmelin

::: mail/base/content/mailWindowOverlay.js
@@ +221,5 @@
>                              "bodyFeedPerFolderPref"];
>    let checked = FeedMessageHandler.onSelectPref;
> +  for each (let [index, id] in Iterator(viewRssMenuItemIds)) {
> +    document.getElementById(id)
> +            .setAttribute("checked", index == checked);

[i wonder if setting the checked property instead of the attribute would have fixed it?]
Attachment #664644 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/56461e6f48d3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0

Updated

5 years ago
Blocks: 787612
(Assignee)

Updated

4 years ago
Duplicate of this bug: 866498
View > Message Body As > ...

This bug fixed functionality of feed body view modes:
  Web Page | Summary | Default Format
The other half of the menu, functionality of HTML rendering pref, was fixed in bug 866498:
  Original HTML | Simple HTML | Plain Text

Setting dependency for ease of tracking.

Related Bug 550794 is about putting {Feed view modes} vs. {HTML rendering prefs} into the right order (proposed solution: Feed view modes first).
Depends on: 866498
See Also: → bug 550794
Summary: Feed body AppMenu items are not working anymore → Feed body views AppMenu items are not working anymore ( [ ≡ ] > View > Feed Message Body As > Web Page | Summary | Default Format)
You need to log in before you can comment on or make changes to this bug.