Allow filtering by product and version.

VERIFIED FIXED

Status

Input Graveyard
Dashboard
P1
normal
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: mythmon, Assigned: willkg)

Tracking

Details

(Whiteboard: u=dev c=general p= s=input.2013q2)

(Reporter)

Description

6 years ago
Allow filtering by product, channel, and version, to match old input.

Making this a one pointer because it should tie well into the already existing filtering system.
Removing sprint info for now.
Whiteboard: u=dev c=infrastructure p=1 s=2012.16 → u=dev c=infrastructure p=1 s=
Duplicate of this bug: 857173
Putting these in my queue for this quarter.
Assignee: mcooper → willkg
Whiteboard: u=dev c=infrastructure p=1 s= → u=dev c=general p= s=input.2013q2
If you go to https://input.mozilla.org/ you'll notice that there's no way to filter by product, channel and version.

In old Input, there was a drop down for product and one for version and they were independent of each other. I think that doesn't really work here. I think it'd be better to do a single dropdown with the product/version combinations. Perhaps with the ones that will most likely be commonly used at the top (most recent three versions for each product?).

You could get the list of product-versions from the database or from ElasticSearch.

Let's push off filtering on channels to a new bug once we have channel-specific feedback.

This is important to get done soon. Let's aim to get this done in April. If no one takes it by then, I'll un-mark it as mentored and do it myself.

This bug is mentored. If you're interested in working on it, add a comment here or ping willkg in #input on irc.mozilla.org.
Priority: -- → P1
Somehow I added a comment about making this bug mentored, but I never actually tagged it as such.

Regardless, taking it to work on it now.

I'm tweaking the scope so it only covers product and version since we're not tracking channels.
Summary: Allow filtering by product, channel, and version. → Allow filtering by product and version.
Landed in master in: https://github.com/mozilla/fjord/commit/4e76587

Minor issue found after I pushed to master fixed in PR: https://github.com/mozilla/fjord/pull/109

Landed minor issue fix in master in: https://github.com/mozilla/fjord/commit/c92af0e
One last one in PR: https://github.com/mozilla/fjord/pull/111

Landed in master: https://github.com/mozilla/fjord/commit/d1aae0d

That looks correct on input-dev. I'll push it to prod tomorrow.
Status: NEW → ASSIGNED
Pushed to prod just now.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
Looks awesome. Thanks a bunch!
Status: RESOLVED → VERIFIED
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.