Say how long the log was before truncation

RESOLVED DUPLICATE of bug 958327

Status

Release Engineering
General
P3
enhancement
RESOLVED DUPLICATE of bug 958327
6 years ago
2 months ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildbot])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
"Output exceeded 52428800 bytes, remaining output has been truncated"

Should say how long the original was, so we know how close we are to getting everything visible.

(e.g. https://tbpl.mozilla.org/php/getParsedLog.php?id=15458553&tree=Firefox )
Created attachment 664309 [details] [diff] [review]
patch

I'm on a roll with issues related to Valgrind today.

This patch changes output to:

Output of x bytes exceeded y bytes, remaining output has been truncated

where x and y are numbers.
Assignee: nobody → gary
Status: NEW → ASSIGNED
Attachment #664309 - Flags: review?(catlee)
(Reporter)

Comment 3

6 years ago
Comment on attachment 664309 [details] [diff] [review]
patch

To use a tuple on the RHS of %, you need to wrap it the tuple in parens.
Comment on attachment 664309 [details] [diff] [review]
patch

Review of attachment 664309 [details] [diff] [review]:
-----------------------------------------------------------------

that doesn't interpolate the way you want it to. also, that message is generated as soon as the log limit is exceeded, and we don't know how large the log is yet.
Attachment #664309 - Flags: review?(catlee) → review-
Created attachment 664313 [details] [diff] [review]
patch v2, not working

This merely provides more information about the amount of excess bytes it went over, it doesn't yet address the issue catlee pointed out, who suggests that we might have to wait till the end, in finish().
Attachment #664309 - Attachment is obsolete: true
Unfortunately I have to punt on this.
Assignee: gary → nobody
Status: ASSIGNED → NEW

Updated

6 years ago
Priority: -- → P3
Whiteboard: [buildbot]
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 958327
(Assignee)

Updated

2 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.