Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Separators in the message header pane toolbar are not visible, separator and space cannot be removed again from the header pane toolbar

RESOLVED FIXED in Thunderbird 18.0

Status

Thunderbird
Theme
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Joachim Herb, Assigned: Paenglab)

Tracking

11 Branch
Thunderbird 18.0
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird17 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Since between version 10.0.2 and 11.0.1 separators in the header pane toolbar have not been visible anymore. 

If you add a separator to the header pane toolbar (by using the customization drop down menu over the toolbar), the separator is not visible in the toolbar and it can't be removed anymore (other then by selecting default set). Instead an empty space is added to the toolbar.

Actually, (nearly) the same applies to the "space" button: After adding it to the header pane toolbar it cannot be removed anymore.

It worked with version 10.0.2 and does not work with 11.0.1. The problem still exists in the trunk.

Comment 1

5 years ago
Is this a theme or actual toolbar/XUL-implementation problem?
Which platform? Mac has always been 1px wide...
(Assignee)

Comment 3

5 years ago
I see this on XP. I'll check this evening if it also happens on Win7 and Linux.

Mark, the problem is the separator has a height of 0px. If you see the separator on OSX then OSX isn't affected by this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
Same on Linux, it's impossible get the "hand" cursor over a separator when customizing the message-header toolbar.
Component: Message Reader UI → Theme
(Reporter)

Comment 5

5 years ago
I see the problem on Windows 7
(Assignee)

Comment 6

5 years ago
Created attachment 665069 [details] [diff] [review]
patch

I checked also under OSX and the separator isn't visible.

Adding the height make it visible. On main toolbar the separator is still stretched to full height.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #665069 - Flags: ui-review?(bwinton)
Attachment #665069 - Flags: review?(bwinton)
Comment on attachment 665069 [details] [diff] [review]
patch

This seems to fix the problem, so ui-r=me.
And the code seems fine, too, so r=me.

Thanks,
Blake.
Attachment #665069 - Flags: ui-review?(bwinton)
Attachment #665069 - Flags: ui-review+
Attachment #665069 - Flags: review?(bwinton)
Attachment #665069 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/e574e51bdd28
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0
(Assignee)

Comment 9

5 years ago
Comment on attachment 665069 [details] [diff] [review]
patch

[Approval Request Comment]
It's only a small CSS patch which could make user's life easier. But it's not so important when it doesn't land as it took 5 versions until the bug is found.
Attachment #665069 - Flags: approval-comm-aurora?
Attachment #665069 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/31fc84ae271b
status-thunderbird17: --- → fixed
You need to log in before you can comment on or make changes to this bug.