[Request Commit Access (Level 1) for Sina Momken] no wikipedia-he.xml while it's listed in http://hg.mozilla.org/l10n-central/he/file/aa010a58427e/mobile/searchplugins/list.txt

RESOLVED FIXED

Status

Mozilla Localizations
he / Hebrew
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Sina Momken, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fennec,Hebew,Search_Plugins)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

If you want to make a multi-locale fennec for android with Hebrew locale added (for more info see http://escapewindow.dreamwidth.org/234671.html) you'll get an error in step mozharness/scripts/multil10n.py --cfg myconfig.py --add-locales.
After investigating you can find out that also l10n/he/browser/searchplugins/list.txt contains "wikipedia-he" but there's no "wikipedia-he.xml" in path l10n/he/browser/searchplugins/ which will result in adding locale he to fennec



Actual results:

As the result you can not add locale he to fennec. I guess you'll get same error if you use Compare-locales too.


Expected results:

I created a wikipedia-he.xml in the mentioned location and copied the corrected http://hg.mozilla.org/l10n-central/he/file/aa010a58427e/browser/searchplugins/wikipedia-he.xml to there. (Also see bug https://bugzilla.mozilla.org/show_bug.cgi?id=794123).
Then I changed the template in wikipedia-he.xml to "http://he.m.wikipedia.org/wiki/מיוחד:Search" which is mobile-specific. After that I could successfully add he-locale to fennec.
(Reporter)

Comment 1

6 years ago
Created attachment 664540 [details]
Reporter's SSH public key to access commit to correct the bug

This is reporter's SSH public key yo access commit to correct the bug.
As the author my name is Sina Momken and I want to use digitsm@gmail.com as the email I want to use to login
(Reporter)

Comment 2

6 years ago
I've sent in the Agreement(http://www.mozilla.org/hacking/notification/)
(Reporter)

Updated

6 years ago
See Also: → bug 794123
(Reporter)

Updated

6 years ago
Whiteboard: Fennec,Hebew,Search_Plugins

Comment 3

6 years ago
(In reply to Sina Momken from comment #0)
Please attach here your suggested changes so someone could review it and decide if we can commit it…

Comment 4

6 years ago
Sina, the issue you found was correct, but the proposed solution is not. At mozilla, we're granting access to our version control systems after contributions have been reviewed.

This particular issue is actually fixed on aurora, and I've just merged the repos back to central.

Also, fennec doesn't support RTL languages at this point, so the search plugin is the least of all problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
@Axel Hecht:
I thought RTL languages support is more android specific than app specific.
Technically speaking, the default android don't support RTL languages until jellybean, but on some particular ROMs like CM7, CM9 and samsung roms (for mideast) you can use RTL languages in all your apps.
So fixing this issue can fix that at least for those roms.
Is this issue fixed by merging the repos?
(Reporter)

Comment 6

6 years ago
@Axel: I've tried twice. You're right. RTL doesn't work well in fennec and letters are seperated.
This is a very big issue because most of other android browsers (specially those based on webkit) show RTL languages correct in the ROMs I've mentioned before.
You need to log in before you can comment on or make changes to this bug.