Closed Bug 794142 Opened 7 years ago Closed 7 years ago

failing talos test: test_configuration.py

Categories

(Testing :: Talos, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: k0scist, Unassigned)

References

Details

Attachments

(1 file)

======================================================================
FAIL: test_extend (test_configuration.TestTalosConfiguration)
test extending configuration from a .config file
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhammel/talos/tests/test_configuration.py", line 21, in
  test_extend
    self.assertTrue(os.path.exists(addon_config))
AssertionError: False is not true

----------------------------------------------------------------------
So looking at this test, I think we can just remove it.  We only check for stuff that we have changed over time including the addon.config file that no longer exists.  I vote for removing this test and filing a subsequent bug to test configuration more rigorously.
Attachment #664559 - Flags: review?(jmaher)
Comment on attachment 664559 [details] [diff] [review]
remove test and fix runtest.py permissions

Review of attachment 664559 [details] [diff] [review]:
-----------------------------------------------------------------

can we test another part of the configuration, why are we removing this file?
The current file doesn't test anything we actually care about testing.  We test addons.config which no longer exists, and xperf.config, which has been changed so much that the things that we test fail.  As said in comment 1 , we should file a bug about actually testing the configuration, but our current tests don't do that.  I don't want to block having green tests on removing tests that are broken.
Attachment #664559 - Flags: review?(jmaher) → review+
pushed to talos: http://hg.mozilla.org/build/talos/rev/5d364368d7b3
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Noted the need for configuration tests as https://bugzilla.mozilla.org/show_bug.cgi?id=794292
Depends on: 801633
You need to log in before you can comment on or make changes to this bug.