Firefox startup crash in nsUrlClassifierPrefixSet::StoreToFile

RESOLVED DUPLICATE of bug 721196

Status

()

Toolkit
General
--
critical
RESOLVED DUPLICATE of bug 721196
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

16 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [startupcrash], crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-dd5c2070-ed67-48ea-b476-bf0de2120925 .
============================================================= 

This signature showed up in the explosive report today - https://crash-stats.mozilla.com/report/list?signature=nsUrlClassifierPrefixSet::StoreToFile%28nsIFile*%29 links to the reports which are almost all Windows XP. Not super high volume but it is happening in Firefox 16 beta as well.

Will hunt down some correlations, but in the meantime adding Gian-Carlo since he shows up as touching that code recently. This signature has been around in low volume for some time but the crash table shows an increase starting with 2012090515 build.
Frame 	Module 	Signature 	Source
0 		@0x552e579 	
1 	xul.dll 	nsUrlClassifierPrefixSet::StoreToFile 	toolkit/components/url-classifier/nsUrlClassifierPrefixSet.cpp:518
2 	xul.dll 	nsUrlClassifierDBServiceWorker::ConstructPrefixSet 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3689
3 	xul.dll 	nsUrlClassifierDBServiceWorker::LoadPrefixSet 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3742
4 	xul.dll 	nsUrlClassifierDBServiceWorker::OpenDb 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:3489
5 	xul.dll 	nsUrlClassifierDBServiceWorker::BeginUpdate 	toolkit/components/url-classifier/nsUrlClassifierDBService.cpp:2889
6 	xul.dll 	UrlClassifierDBServiceWorkerProxy::BeginUpdateRunnable::Run 	toolkit/components/url-classifier/nsUrlClassifierProxies.cpp:73
7 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
8 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:257
9 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:395
10 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
11 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
12 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
13 	kernel32.dll 	BaseThreadStart
(Reporter)

Updated

5 years ago
Version: unspecified → 16 Branch
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 721196
>Will hunt down some correlations

That would be good...when I analyzed this code in the other bug I couldn't find any way this can actually crash like it is in Firefox code itself. It looks like something is hooking us...
You need to log in before you can comment on or make changes to this bug.