bring mac minis to certified tech in desktop

RESOLVED FIXED

Status

Infrastructure & Operations
DCOps
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: van, Assigned: ashlee)

Tracking

Details

(Whiteboard: [mtv-desktop] )

(Reporter)

Description

5 years ago
talos-r4-lion-058 - host had memory issues and ram was replaced but looks like issues are persisting. will need to bring to apple certified tech in desktop to rerun diagnostics.

talos-r4-snow-030 - bad onboard NIC, confirmed switch port and cable works fine. will need to bring to apple certified tech to swap out motherboard if possible.

talos-r3-xp-048 - dead drive. if desktop can pick up the exact hard drive to replace, we can replace the drive otherwise we'll have to retire.

talos-r4-snow-050 - bad hardware, system does not stay powered on - flickers on and off.
(Reporter)

Updated

5 years ago
Assignee: server-ops → sespinoza
Dropped off the minis in the desktop area.

Updated

5 years ago
Blocks: 789662

Updated

5 years ago
Blocks: 793945
(Reporter)

Updated

5 years ago
colo-trip: --- → mtv1
Whiteboard: [mtv-desktop]

Comment 2

5 years ago
Lion-058:  Ran diagnostics several times again but did not find any errors. Will put back into production.

Snow-030:  Has bad onboard NIC. Hardware is out of warranty. Need to decommission.

XP-48:  Has bad hard drive. Will replace HDD with spare one in stock.

Snow-50:  Has bad logic board. Hardware is out of warranty. Need to decommission.
Now that we have a certified tech, what does it cost us to repair those machines (presumably we only have to purchase parts)?

Comment 4

5 years ago
Hard drives and memory can be easily replaced.  As for other hardware parts, it's all integrated onto the motherboard. Replacing the motherboard is tedious on any apple products.
Unfortunately, tedium doesn't factor into this much.  :}

We can't replace these, so we need to know what it costs for parts to fix them.  

This was part of our whole request of having a certified apple tech in house (so we had someone who could do the repairs as opposed to us sending it out to a third party).

Comment 6

5 years ago
talos-r3-xp-048 - Hard drive has been replaced and reimaged.

vhua$ sudo fping talos-r3-xp-048.build.scl1.mozilla.com
talos-r3-xp-048.build.scl1.mozilla.com is alive

[snow-30 & snow-50] - The cost to replace the logic board on the r4 mac mini's is $591.77 each.  

Let me know if you want to proceed with ordering the replacement boards.
releng folks: We can't get any more r4s.  Should we pay the $600 to repair these two?
I'm on the hook to get you an answer - please let me know if there are any deadlines we're approaching.
No deadlines, no (since we're out of warranty), it just means that the machines sit out of commission longer.
Hal, what was the verdict on this?  Are we paying to repair the r4s?
Yes - we'll repair these 2. Not a policy yet, though.
Blocks: 730545
Blocks: 731304
No longer blocks: 793945
Blocks: 793945
Can someone form desktop or dcops please confirm that these two machines have been sent for repair?  When will they be back in service again?

talos-r4-snow-030.build.scl1.mozilla.com
talos-r4-snow-050.build.scl1.mozilla.com

Comment 13

5 years ago
Amy,
I will have desktop order the replacement logic boards today.

Comment 14

5 years ago
Logic boards for the mac minis have been ordered today by Patrick Dang.
(Assignee)

Updated

5 years ago
Assignee: sespinoza → achavez
Status: NEW → ASSIGNED

Comment 15

5 years ago
Snow-30 and snow-50 as been repaired and re-racked.  Since both logic boards were replaced, they now have new  nic MAC addresses.  

snow-30 = C4:2C:03:0A:D2:DC

snow-50 = C4:2C:03:0A:CB:C7
Updated in inventory and added to deploystudio.  Do we need to reimage these, vihn?  If so, can you do that, please?
They were up enough so that I could get into them, but they looked like they needed a reimage, so that's been done.  releng, snow-050 and snow-030 should be tested out.  I commented in 730545 since it looks like lion-058 got tested after the memory was replaced.
(In reply to Amy Rich [:arich] [:arr] from comment #17)
> They were up enough so that I could get into them, but they looked like they
> needed a reimage, so that's been done.  releng, snow-050 and snow-030 should
> be tested out.  I commented in 730545 since it looks like lion-058 got
> tested after the memory was replaced.

snow-030 and snow-050 are having dongle issues: bug 814260

Comment 19

5 years ago
I'm assuming we can close this bug out since all the bad mac minis have been addressed. There is a separate bug to address the dongle issues with snow-30 & 50.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
talos-r4-lion-058 still hasn't been addressed/fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 21

5 years ago
Ran a full diagnostics check on talos-r4-lion-058 using TechTool Pro and no issues were found. Host had passed hard disk, video, and memory checks.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.