Last Comment Bug 794253 - Firefox doesn't delete cookies when quiting
: Firefox doesn't delete cookies when quiting
Status: RESOLVED DUPLICATE of bug 530594
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: 15 Branch
: x86_64 Windows 7
: -- critical with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :Ehsan Akhgari
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 14:46 PDT by Frank Breitling
Modified: 2012-11-02 01:38 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frank Breitling 2012-09-25 14:46:52 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I set Firefox Preferences to:
Privacy->+Clear history when Firefox closes->Settings->+Cookies


Actual results:

I closed Firefox but my cookies were not deleted.


Expected results:

The cookies should be deleted.

Bug 443354 suggest that this behavior is caused by the setting:
General->Show my windows and tabs from last time

This setting does not only restore the URLs but the complete sessions even if in conflict with the privacy settings. Since privacy should have higher (if not highest) priority, only the URLs should be restored while the cookies should be deleted in this case.
Comment 1 Jesse Ruderman 2012-09-25 16:57:12 PDT
Will probably be fixed in bug 401187.  See also bug 530594.
Comment 2 alex_mayorga 2012-10-02 14:12:52 PDT

*** This bug has been marked as a duplicate of bug 401187 ***
Comment 3 Frank Breitling 2012-10-07 11:15:31 PDT
This is only a duplicate of bug 401187 if bug 401187 is not about rewording but resolving the problem of FF not deleting cookies.
Until this has been confirmed it is not a duplicate.
Comment 4 htmlvb 2012-10-16 16:10:51 PDT
http://zpao.com/posts/restore-previous-session/

Set both settings to 2; It works for me.
Comment 5 Frank Breitling 2012-11-02 01:38:54 PDT

*** This bug has been marked as a duplicate of bug 530594 ***

Note You need to log in before you can comment on or make changes to this bug.