Update Linux System Requirements for Firefox 17

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
The build environment changed for Linux builds during Firefox 18 development, so we now require
 GTK+ 2.18 or higher
 GLib 2.22 or higher

Please update the system requirements page when FF18 merges to beta.
We're actually hoping to have this in 17 soon. See bug 794185.
bug 794285 is going to make the requirements back to gtk+ 2.10 or higher (thanks to thunderbird builders not being up-to-date)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

6 years ago
Is this still wontfix if we are moving thunderbird into a centos6 mock environment (to match firefox), uplifting support to aurora, and blocking updates to gtk < 2.18 ?
Unless we backout bug 794285, we still have build-time compatibility with gtk 2.10 (not runtime compatibility when built against 2.18, though, which is why the blocklist is important).
(Reporter)

Comment 5

6 years ago
<glandium> nthomas: we are build-time dependent on 2.10, but the builds we ship depend on 2.18

So we should update the runtime requirements on www.mozilla.org
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Update Linux System Requirements for Firefox 18 → Update Linux System Requirements for Firefox 17
This was taken care of over at bug 814456 - but next time let's not close this sort bug so hastily and without nominating for release tracking :)
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.