Nested OPTGROUP outdents too much

RESOLVED DUPLICATE of bug 1214164

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 1214164
17 years ago
2 years ago

People

(Reporter: james, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Optgroup is a nest-able control for creating a heriarchy of grouped options
within a SELECT element. When one optgroup is nested within another one, after
the closing optgroup tag, the list appears to be out-dented.
I see this too (Linux build 2001-05-07-08).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

17 years ago
OPTGROUP isn't nestable, according to the HTML 4.01 recommendation, so this
would be invalid anyway. However, the browser should ignore invalid code, not go
nuts. I'll try to get a testcase made to demonstrate the described situation.

Comment 3

17 years ago
Created attachment 37115 [details]
OPTGROUP testcase

Comment 4

17 years ago
The results are reasonable: In 2001060409 Win98, the browser is expecting users
to leave their OPTGROUP tags open, so when it finds an OPTGROUP tag before the
closing /OPTGROUP, it tries to start a new OPTGROUP as though the previous has
ended, and disregards the extra closing tag later on. The recommendation does
require an end tag, so it wouldn't be unreasonable to go ahead and support
nested OPTGROUPS rather than behave this way, but that would be going above and
beyond when at the same time Netscape's having enough trouble keeping the
program from crashing and losing data.

You can go ahead and change the OS to All, though.
Keywords: testcase
OS: Linux → All
Hardware: PC → All
*** Bug 92241 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
It makes you wonder what happened to proposals like this:

http://lists.w3.org/Archives/Public/www-html/1997Sep/0347.html
They died the death of being involved with www-html.

Updated

13 years ago
Assignee: rods → nobody
Status: ASSIGNED → NEW
QA Contact: vladimire → layout.form-controls
Nested optgroups aren't allowed, and their contents are supposed to just be ignored, which will be fixed with bug 1214164.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214164
You need to log in before you can comment on or make changes to this bug.