CSS3 animation is broken, background color does not perform animation

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: mattwoodrow)

Tracking

({regression, reproducible})

18 Branch
x86
Windows 7
regression, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by Bug 539356)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 664849 [details]
sample html

http://hg.mozilla.org/mozilla-central/rev/08d435dedc7f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120925030547

Steps to reproduce:
1. Open attached
2. Observe color

Actual results:
 Backgoround color is changed suddenly

Expected results:
 Backgoround color should perform animation.
 Red->orangish->Yellow->orangish->Red

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f7c89de3ab43
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120915201302
Bad:
http://hg.mozilla.org/mozilla-central/rev/b3f462d96fb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916161603
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=b3f462d96fb5


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/33087122ace7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916022601
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6ee831a85d12
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120916033402
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=33087122ace7&tochange=6ee831a85d12
Suspected: Bug 788044
tracking-firefox18: --- → ?

Updated

5 years ago
tracking-firefox18: ? → +
Keywords: reproducible
Matt, passing this on to you as it is a suspected regression from Bug 788044
Assignee: nobody → matt.woodrow
(Reporter)

Comment 2

5 years ago
I cannot reproduce anymore in Aurora18.0a2 and Nightly19.0a1 as well.
http://hg.mozilla.org/releases/mozilla-aurora/rev/53559d475428
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121015042010
http://hg.mozilla.org/mozilla-central/rev/8f145599e4bf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121016030544


Fixed window
Bad:
http://hg.mozilla.org/mozilla-central/rev/b274e8e3479f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928160219
Fixed:
http://hg.mozilla.org/mozilla-central/rev/b62b229a4d41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928161018
Fixed Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b274e8e3479f&tochange=b62b229a4d41

I guess this was fixed by Bug 539356
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-firefox18: + → ---
Resolution: --- → WORKSFORME
Whiteboard: fixed by Bug 539356
You need to log in before you can comment on or make changes to this bug.