SVG image loading causes firefox hangup on i686 linux

RESOLVED DUPLICATE of bug 767056

Status

()

RESOLVED DUPLICATE of bug 767056
6 years ago
6 years ago

People

(Reporter: blues, Unassigned)

Tracking

15 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 664853 [details]
1.svg

User Agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20120829 Firefox/15.0 Iceweasel/15.0
Build ID: 20120829195215

Steps to reproduce:

Please, open that url: http://www.blues.gda.pl/1.svg



Actual results:

Firefox hangup with 100% CPU usage.
Confirmed on i686 linux version. 64bit version is _not_ affected.


Expected results:

svg image displayed
Try 16, 17 or a Nightly it should be fixed there.
(Reporter)

Comment 2

6 years ago
Created attachment 664861 [details]
Causes SIGSEGV

this part of svg causes firefox to crash
Can you try a newer version please? Beta, Aurora or a Nightly?

Updated

6 years ago
Component: Untriaged → SVG
Product: Firefox → Core
(Reporter)

Comment 4

6 years ago
The bug is gone on aurora 17.0a2.
The question is: bug is fixed or will appear in another place?
must be bug 767056 then

What other place? bug 767056 is fixed from Firefox 16 onwards.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767056
You need to log in before you can comment on or make changes to this bug.