[dev]Searching for a library just created does not return the library when searching for it

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Add-on Builder
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 664908 [details]
Creating the library

1.Go to https://builder-addons-dev.allizom.org/
2.Login
3.Click "Create Library" button from the button of the page
4.Input package version: "searchable" and hit save
5.After successfully creating the library click search and input the library name

Expected results:
First library result should be the created library

Actula results:
Library isn't found.
(Reporter)

Comment 1

5 years ago
Created attachment 664910 [details]
Searching for the library

Comment 2

5 years ago
Just to add that we are not exactly sure what the problem is here.

Our automated test will wait 120 seconds for it to appear and this works just fine for Addon packages. But for libraries it is failing consistently. That is, the library does not appear in the search results for 

It could also be a problem with the search matching. Maybe the search does not prioritise a match even when the search string is the exact match of the package title.
(Reporter)

Comment 3

5 years ago
Just to be clear, the problem is that the library isn't found in the search results whatsoever.
The fact that the first library isn't shown first, is the secondary issue.
The builder project has been discontinued as of April 1st, 2014.

The announcement last year: https://blog.mozilla.org/addons/2013/12/18/add-on-builder/

Next steps (still being written): https://developer.mozilla.org/en-US/Add-ons/SDK/Builder
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.