Calculated hash for file uploaded and addon available on AMO differ

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: martin.andre, Unassigned)

Tracking

Details

Attachments

(2 attachments)

162.29 KB, application/octet-stream
Details
162.29 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 664962 [details]
original_file.xpi

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.7) Gecko/20100101 Firefox/10.0.7 Iceweasel/10.0.7
Build ID: 20120831075225

Steps to reproduce:

I uploaded my addon with hash d8585acaab5935c8d0b48ed13123db8870254e7f4c9ce6512be901f5c409d7f8 to AMO.
$ sha256sum ~/dev/Grooveshark-Simple/gs-simple.xpi
d8585acaab5935c8d0b48ed13123db8870254e7f4c9ce6512be901f5c409d7f8  /home/martin/dev/Grooveshark-Simple/gs-simple.xpi


Actual results:

The file I download from AMO has a different hash:
$ wget https://addons.mozilla.org/firefox/downloads/file/169296/grooveshark_simple-0.1-fx.xpi -O - | sha256sum
--2012-09-26 23:36:15--  https://addons.mozilla.org/firefox/downloads/file/169296/grooveshark_simple-0.1-fx.xpi
Resolving addons.mozilla.org (addons.mozilla.org)... 63.245.217.112
Connecting to addons.mozilla.org (addons.mozilla.org)|63.245.217.112|:443... connected.
HTTP request sent, awaiting response... 302 FOUND
Location: https://addons.mozilla.org/_files/398402/grooveshark_simple-0.1-fx.xpi [following]
--2012-09-26 23:36:16--  https://addons.mozilla.org/_files/398402/grooveshark_simple-0.1-fx.xpi
Reusing existing connection to addons.mozilla.org:443.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://addons.cdn.mozilla.net/_files/398402/grooveshark_simple-0.1-fx.xpi [following]
--2012-09-26 23:36:16--  https://addons.cdn.mozilla.net/_files/398402/grooveshark_simple-0.1-fx.xpi
Resolving addons.cdn.mozilla.net (addons.cdn.mozilla.net)... 184.26.212.61
Connecting to addons.cdn.mozilla.net (addons.cdn.mozilla.net)|184.26.212.61|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 166186 (162K) [application/x-xpinstall]
Saving to: ‘STDOUT’

100%[======================================>] 166,186     1002KB/s   in 0.2s   

2012-09-26 23:36:17 (1002 KB/s) - written to stdout [166186/166186]

9c69586e7864668dc761a14ba405e6b312c9d7d92f5de80433770c98244beffd  -


Expected results:

Both files should have hash d8585acaab5935c8d0b48ed13123db8870254e7f4c9ce6512be901f5c409d7f8.
(Reporter)

Comment 1

6 years ago
Created attachment 664967 [details]
downloaded file
(Reporter)

Comment 2

6 years ago
I forgot to mention that I upload the addon several times, built with a different version of the AddonSDK. As eviljeff mentioned on irc.mozilla.org#addons,this could be a mirror issue.
could be connected to / a dupe of bug 794112
Status: UNCONFIRMED → NEW
Ever confirmed: true
From further talking, its more likely this is a possible regression of bug 709648 so don't know if we want to re-open that instead and dupe this?
Component: Add-on Validation → Public Pages
Does recalculating the hash fix it?
It seems to be working today, though that may just be because I'm hitting a different mirror.  It would be good if we could confirm all the mirrors have the correct file somehow?
I'm going to close this then.

Verifying the files on the mirrors would be a question for IT.  I'd expect it to be difficult.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.