Buttons that should not be disabled gets disabled by an auto-complete bug?

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Jan Henrik, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 665076 [details]
Test-page for the bug (refresh using CTRL+R if problem does not manifest on first load)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I had a webpage with some buttons, and some of the buttons that never should be disabled was disabled. I tried looking for scripts and found that no scripts did anything to those buttons.

I tried to find an answer to why this was happening, and came across this:
http://stackoverflow.com/questions/5985839/bug-with-firefox-disabled-attribute-of-input-not-resetting-when-refreshing

So after some testing i was able to isolate the bug and build a test-page (see attachment).

The behavior seen in the first test must be a bug in the auto-complete "feature"?


Actual results:

Buttons that should not be disabled seemingly gets disabled by Firefox's auto-complete feature. (See attached test case)


Expected results:

Buttons should not magically get disabled because Firefox tries to keep some previous state but disables the wrong buttons when trying to disable them.
(Reporter)

Updated

5 years ago
Attachment #665076 - Attachment mime type: text/plain → text/html
confirming with Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
works with Opera12
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
(Reporter)

Updated

5 years ago
Summary: Buttons should not be disabled gets disabled by an auto-complete bug? → Buttons that should not be disabled gets disabled by an auto-complete bug?
This is a duplicate.  Please feel free to find the original and mark this accordingly.
Whiteboard: DUPEME
(Reporter)

Comment 3

5 years ago
(In reply to Boris Zbarsky (:bz) from comment #2)
> This is a duplicate.  Please feel free to find the original and mark this
> accordingly.

I did some searching and found similar bug reports, but none in which auto-complete mistakenly disables the wrong button. So i'd say it is _not_ a duplicate.

This bug report also includes a test-page where it can be easily confirmed and tested.
Whiteboard: DUPEME
(Reporter)

Comment 4

4 years ago
Almost a year old now. Problem still exists. Can someone please look at this?
(Reporter)

Updated

4 years ago
Version: 15 Branch → Trunk
(Reporter)

Comment 5

4 years ago
Seems to be fixed in Firefox 27.0.1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.