Basic HTML tests aren't working in tinderbox builds

RESOLVED DUPLICATE of bug 795487

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 795487
6 years ago
6 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Download and install Alder branch from tinderbox (for example https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/alder-macosx64/1348623197/firefox-18.0a1.en-US.mac.dmg)
2. Clone alder branch (hg clone http://hg.mozilla.org/projects/alder)
3. Open tinderbox build
4. Enter location of HTML test file in address bar and and hit return (file:///path/to/alder/dom/media/tests/local_video_test.html)
5. Click Start!

Expected:
Video feed will display from input device

Actual:
Nothing happens

Additional:
After clicking Start! the following error appears in the Error Console

Error: ReferenceError: mozRTCPeerConnection is not defined
Source File: file:///Users/dhunt/workspace/alder/dom/media/tests/local_video_test.html
Line: 75
So, on mozqa.com we have a basic test for mozGetUserMedia:
http://mozqa.com/data/webapi/camera/video_basic.html

Retrieving the video works fine that way. So something is broken with the RTC code then. I don't see your above mentioned error when running the referenced test locally. The Error console stays blank. Also when I run it in my debug build (created on Monday this week) I have the same problem. It's just a white area and nothing more.

Jason, this blocks our work on test automation. It would be great if we can get this sorted out as best today. Would you have the time to help? It would be really appreciated. 

It would be good to know if that also happens on other platforms or only Mac.
Worked with a tinderbox build from 9/24 (monday) on Linux.  Note: this morning's tinderbox has a bug in the DOM code with onRemoteStreamAdded
henrik: can you capture the output (I assume it's a debug build?) and attach it?  Also what rev is it build from (hg tip).  Thanks
So what I can see now is that the above two video nodes are not from the local box. If you want to see the video click on start and check the latest video node. It displays it fine for me now.

Could this have been the same issue as bug 795487?
Issue in the test from changing from src to mozSrcObject. Old and outdated, but not a bug. Closing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795487
(Reporter)

Comment 6

6 years ago
I can confirm that latest tinderbox/tests works for me.
You need to log in before you can comment on or make changes to this bug.