Closed Bug 794684 Opened 7 years ago Closed 7 years ago

Hang when printing selected text from a bugzilla bug (when logged in to bugzilla)

Categories

(Core :: Printing: Output, defect, major)

x86_64
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 794579

People

(Reporter: jmjjeffery, Unassigned)

References

Details

(Keywords: hang, regression)

Attachments

(1 file)

It was requested to file a separate bug for 'selected text' and trying to print the selection is causing the browser to hang.

Spun off from bug 794579
Was suggested to use: https://ftp.mozilla.org/pub/mozilla.org/README
Selecting the text from the link and choosing Print->Print-> from the Nightly/Firefox button prints OK for me without problem.  That link is just plain text on a plain non-nonsense page. 

Selecting any text from any comment say in bug 794579 and choosing Print->Print as above will hang the browser...
Couldn't reproduce initially (using a fresh profile), but once I logged into bugzilla I was able to reproduce.

Linux 64-bit, latest Nightly
Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0

Here are some exact STR:
 0) start with fresh profile
 1) visit https://bugzilla.mozilla.org/show_bug.cgi?id=794579
 2) log in to bugzilla using the form at the top (IMPORTANT that you're logged in
 3) Highlight the first word in the first comment ("Attempting")
 4) Print selection. (File Print, toggle the "selection")
OS: Windows 7 → All
I get the same regression range for this as for bug 794579, so it may end up being the same underlying cause - can't be sure at this point.  But they do both seem to be regressions from bug 468568.

m-i regression range:
Good: https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-09-19-mozilla-inbound-debug/firefox-18.0a1.en-US.debug-linux-x86_64.txt
Bad: https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-09-20-mozilla-inbound-debug/firefox-18.0a1.en-US.debug-linux-x86_64.txt

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6eed25d2f2c9&tochange=b3e66a4b7c0b
Blocks: 468568
Keywords: hang, regression
Summary: Printing Selected Text causes browser to hang → Hang when printing selected text from a bugzilla bug (when logged in to bugzilla)
Added attachment showing selected text and dialog box of the Hang...
Is this fixed by the check-in for bug 794579?
(In reply to Bill Gianopoulos [:WG9s] from comment #4)
> Is this fixed by the check-in for bug 794579?

Seems to be, not hanging when printing selected text now.  

marking as a dupe to 794579
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 794579
You need to log in before you can comment on or make changes to this bug.