jsonrpc processes spawn locking up server

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jpeterse77, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231657

Steps to reproduce:

Fresh install of Bugzilla 4.2.3 on CentOS, and Testopia installed as well.
Issue appear when entering new component. Upon submitting the new component, system spawns off a rash of jsonrpc.cgi processes


Actual results:

JSONRPC process consumed 100% of CPU resources, and server became inaccessible.
Eventually jsonrpc processes timed out with an error message in the logs.
Timeout waiting for output from CGI script /usr/share/bugzilla/latest/jsonrpc.cgi, referer: 

Issue can be overcome by disabling autocomplete.


Expected results:

Autocomplete should have returned a set of names matching the entered name in the assignee field

Comment 1

6 years ago
This has nothing to do with bug 685552. This bug implemented the ability to disable auto-completion if your server is unable to support this feature, which seems to be the case of your server. So turn off auto-completion and the problem will go away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Summary: Regression of bug 685552 - jsonrpc processes spawn locking up server → jsonrpc processes spawn locking up server
(Reporter)

Comment 2

6 years ago
Hi Frederic

Alright, so maybe it's not a regression, my bad.
But I still can't identify why the auto complete doesn't work and consumes all available resources on the server.
I did a clean install, unpacked the tar ball, and followed the instructions to load the needed modules. One of the modules that the bugzilla installer ended up installing was the json-rpc module which it pulled down from CPAN.
It was installed with the recommended "/usr/bin/perl install-module.pl json-rpc" command. As such, I'm not using a distro packed version of of JSON.

The JSON libraries that the installed ended up installing are:

JSON-RPC v1.03 
JSON-XS v2.33
You need to log in before you can comment on or make changes to this bug.