Closed Bug 794731 Opened 7 years ago Closed 7 years ago

No pages rendered when Nightly launched from cold by opening an URL from another app

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox18 --- verified
fennec 18+ ---

People

(Reporter: nthomas, Assigned: Margaret)

References

Details

(Keywords: regression, reproducible)

I see this with the nightly build from 
 http://hg.mozilla.org/mozilla-central/rev/ca4af4af5334
and is probably a regression from the previous day.

Starting from Nightly not running, if I open a link from the GMail app, or from Google Reader, then Nightly launches and goes through the motions of retrieving the page but doesn't display anything other than the title in the location bar. No page content is shown in other tabs that are opened, eg by using history or a bookmark. Tab previews are visible in the tab switching UI.

After quitting Nightly and start it manually, pasting in the URL gives a properly rendered page and the browser operates normally. Opening a URL from Gmail is also rendered successfully.

I've seen this on a Galaxy Nexus phone (JB) and Galaxy Tab (ICS).
First failing build:
c1003f039c77	Margaret Leibovic — Bug 789887 - Avoid creating unnecessary AboutHomeRunnables. r=lucasr
http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1348523364/fennec-18.0a1.en-US.android-arm.apk

Previous revision on inbound, which is OK:
b01c3760fce6	David Anderson — Use js_free on fresh slots instead of js_delete (bug 793385, r=billm).
http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1348522944/fennec-18.0a1.en-US.android-arm.apk
Blocks: 789887
Product: Fennec → Firefox for Android
STR: adb shell am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d "http://www.mozilla.com"
tracking-fennec: --- → ?
Also, restarting Nightly after a crash triggers this.
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 18+
Duplicate of this bug: 795155
I backed out cset c1003f039c77 (bug 789887) and the problem remains.
(In reply to Mark Finkle (:mfinkle) from comment #7)
> I backed out cset c1003f039c77 (bug 789887) and the problem remains.

Lies. I ran comment 4 with the wrong fennec. Rebuilding and will run again.
After retesting using the right package name, I can confirm that a backout of bug 789887 "fixes" the problem.
backed out bug 789887
https://hg.mozilla.org/mozilla-central/rev/7fffa1ef35d9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
I cannot reproduce this issue on the latest Nightly with the STR from comment #4. Closing bug as verified fixed.

--
Firefox 18.0a1 (2012-10-05)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.