Empty documents when you get 304 after 401?

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Ernst Sjostrand, Unassigned)

Tracking

16 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907230816

Steps to reproduce:

This is a regression in Firefox 16, can't reproduce with Firefox 15.
We have a couple of sites on the intranet that use Kerberos authentication, a Mediawiki, Gerrit, etc.
When they first send a 401 to Firefox 16 for a file and then a 304 response, Firefox 16 shows that file as empty. Sometimes the CSS, sometimes the html body, etc.
Could you please create a http log https://developer.mozilla.org/en-US/docs/HTTP_Logging
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
(Reporter)

Comment 2

5 years ago
Created attachment 666878 [details]
http log

In this run I first load the page and it looks fine.
Then I press reload and then it looks like a .css file becomes empty and I loose all the layout.
Would you help us with a regression range search ?
That will hopefully show us the change that caused this issue.

We have a tool that helps with this task and you have to test only a few builds until it find the last working and the first bad build.

- https://github.com/mozilla/mozregression#readme
(Reporter)

Comment 4

5 years ago
Sure I should be able to try that on monday.
(Reporter)

Comment 5

5 years ago
Mozregression doesn't support being behind an authenticating proxy... :-(
(Reporter)

Comment 6

5 years ago
Haven't seen this in a while.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.