Closed Bug 794766 Opened 7 years ago Closed 7 years ago

B2G Telephony: phone is hanging after a busy call is released by operator

Categories

(Core :: DOM: Device Interfaces, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla18
blocking-basecamp +

People

(Reporter: hsinyi, Assigned: hsinyi)

References

Details

(Whiteboard: [LOE:S])

Attachments

(1 file)

This was originally reported in gaia:
https://github.com/mozilla-b2g/gaia/issues/5229 

STR:
1- place a call from otoro to a remote party. Note, the *voice mailbox* service of the remote number might need to be *disabled*. I cannot reproduce this issue when I dialled another number whose voice mailbox is enabled.
2- remote party not answer the call, and the local party not hang it up, either. Just wait for operator finishing the call.

Actual result: the dialer displays "Calling..." and cannot finish this call anymore (even the call has been released by operator already).
blocking-basecamp, of course...
blocking-basecamp: --- → ?
Whiteboard: [LOE:S]
Attached patch patchSplinter Review
Added call fail causes, and modified response of REQUEST_LAST_CALL_FAIL_CAUSE.
Attachment #665376 - Flags: review?(philipp)
Even though this seems like a corner case, it's bad and we should fix it for v1.
blocking-basecamp: ? → +
Attachment #665376 - Flags: review?(philipp) → review+
https://hg.mozilla.org/mozilla-central/rev/96faff88d792
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 796746
Otoro phone, build 2012-10-02 us
Taken from default.xml in b2g-distro: 
* "platform_build" revision= 795261940c8b11fb7dddd7a8e9dd8561fdc4fb64
* "gaia" revision= 3e360f0875e519743e2ce3159cbb035d5e8334e1 
* "releases-mozilla-central" revision= 4914d55691e8f602f4275d614183a2cde6aa69db
* "gonk-misc" revision= 202d2c62443c098b125e5d9d7b42226d98230e44
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.