Upgrade license to MPL 2 for /suite/installer/license.txt

RESOLVED FIXED in seamonkey2.15

Status

SeaMonkey
Installer
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Philip Chee, Assigned: tonymec)

Tracking

Trunk
seamonkey2.15
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

6 years ago
We appear to be still using the MPL 1.1. Looks like Gerv's script somehow missed this file:

http://mxr.mozilla.org/comm-central/source/suite/installer/license.txt

Updated

6 years ago
Duplicate of this bug: 794776
(In reply to Philip Chee from comment #0)
> We appear to be still using the MPL 1.1. Looks like Gerv's script somehow
> missed this file:
> 
> http://mxr.mozilla.org/comm-central/source/suite/installer/license.txt

Considering that this file is _only_ the license and nothing else, should it be changed to a _copy_ of the MPL2 or just to a _reference_ to it, something like

This Source Code Form is subject to the terms of the Mozilla Public
License, v. 2.0. If a copy of the MPL was not distributed with this
file, You can obtain one at http://mozilla.org/MPL/2.0/.

?
(Reporter)

Comment 3

6 years ago
Good question. This is the Firefox license:

http://mxr.mozilla.org/comm-central/source/mozilla/browser/branding/official/LICENSE
But B2G uses the full license:

http://mxr.mozilla.org/comm-central/source/mozilla/b2g/LICENSE

Lets ask Gerv for a definitive answer.

Note to Gerv, there appears to be several files that still use the old tri-licence:

http://mxr.mozilla.org/comm-central/search?string=tri-license&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
(In reply to Philip Chee from comment #3)
> Good question. This is the Firefox license:
> 
> http://mxr.mozilla.org/comm-central/source/mozilla/browser/branding/official/
> LICENSE

That's not quite so; that's a specific statement to make the license clear about the official branding (hence the directory it's in).

> But B2G uses the full license:
> 
> http://mxr.mozilla.org/comm-central/source/mozilla/b2g/LICENSE
> 
> Lets ask Gerv for a definitive answer.

If it's a copy of the MPL 1.1, let's switch it for a copy of the MPL 2. We can leave the question of "do we actually need a copy of the licence in this place" for another day.

My script only does headers, not full copies. And it ignores files called "LICENSE" or similar.
 
> Note to Gerv, there appears to be several files that still use the old
> tri-licence:
> 
> http://mxr.mozilla.org/comm-central/search?string=tri-
> license&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central

Can you add details to bug 790009, reopening it if necessary?

Thanks,

Gerv
Blocks: 715549
(Reporter)

Comment 5

6 years ago
> If it's a copy of the MPL 1.1, let's switch it for a copy of the MPL 2. We can leave
> the question of "do we actually need a copy of the licence in this place" for another
> day.
Looks like a plan, So Tony you can go ahead with this.

> Can you add details to bug 790009, reopening it if necessary?
I think you meant Bug 760009 which I've updated plus I've added a comment to Bug 715549 for mozilla-central.
Created attachment 666803 [details]
new (MPL2) version of the file

This is the new version of the file, included from the human reader's facility. The patch consists in removing the old file and adding the full text of the MPL2, but diff (or hg, if you will) has tried to "synchronize" deletes and adds in the patch which will soon be added, resulting in something not very legible.
Assignee: installer → antoine.mechelynck
Status: NEW → ASSIGNED
Attachment #666803 - Flags: feedback?(gerv)
Created attachment 666804 [details] [diff] [review]
patch v0

This is the patch which replaces the current (MPL 1.1) version of the file by the text in attachment #666803 [details].
Attachment #666804 - Flags: review?(neil)
Created attachment 666807 [details]
new text v0.1

with more uniform titling…
Attachment #666803 - Attachment is obsolete: true
Attachment #666803 - Flags: feedback?(gerv)
Attachment #666807 - Flags: feedback?(gerv)
Created attachment 666811 [details] [diff] [review]
patch v0.1

…and bug number at the start of the patch comment
Attachment #666804 - Attachment is obsolete: true
Attachment #666804 - Flags: review?(neil)
Attachment #666811 - Flags: review?(neil)
Notes:
1. I made this from the "official" version at http://mozilla.org/MPL/2.0/ which, however, is in HTML, following my own sense of what "the same text" should look like in text/plain format. Only afterward did I notice that the B2G license is in plaintext. If you (Neil & Gerv) prefer an exact copy of the B2G license, just say so.
2. The new text is in UTF-8 (but without BOM), including "smart quotes" (opening “ U+201C and closing ” U+201D) and "smart apostrophes" (’ U+2019), just as in the original HTML document.
Please use the official plain text version:
http://www.mozilla.org/MPL/2.0/index.txt

Thanks :-)

Gerv
(In reply to Tony Mechelynck from comment #10)
> 1. I made this from the "official" version at http://mozilla.org/MPL/2.0/
> which, however, is in HTML, following my own sense of what "the same text"
> should look like in text/plain format.
I mostly prefer your version, except for the lettered lists, which have too much indentation for my liking, i.e.
1.5. "Incompatible With Secondary Licenses"
-------------------------------------------
    means
     a. that the initial Contributor has attached the notice described in
        Exhibit B to the Covered Software; or
     b. that the Covered Software was made available under the terms of
        version 1.1 or earlier of the License, but not also under the terms of
        a Secondary License.
(Sadly the Mozilla HTML to text converter doesn't seem to be able to generate non-numbered ordered lists...)
b2g's asterisks around the disclaimers are a nice touch, but I don't think they belong around the heading.

> 2. The new text is in UTF-8 (but without BOM), including "smart quotes"
> (opening “ U+201C and closing ” U+201D) and "smart apostrophes" (’ U+2019),
> just as in the original HTML document.
If nobody minds, I'd rather you switched to ASCII.
I actually started that comment and got mid-aired but I didn't want to start all over, so I submitted it anyway. It looks as if the official plain text version addresses most of my comments, although I was momentarily confused because it used (a) as its ordered list style.

Gerv, why do the asterisks include the headings, but on the HTML version the highlighting only includes the text?
Comment on attachment 666811 [details] [diff] [review]
patch v0.1

Minusing as per comment #11.
Attachment #666811 - Flags: review?(neil) → review-
neil: I didn't produce the plain text version myself, but anyway forking it is not a good idea, so let's just go with the official one :-)

Gerv
Created attachment 667239 [details]
new text v1 (copy of http://www.mozilla.org/MPL/2.0/index.txt)
Attachment #666807 - Attachment is obsolete: true
Attachment #666807 - Flags: feedback?(gerv)
Attachment #667239 - Flags: feedback?(gerv)
Created attachment 667241 [details] [diff] [review]
patch v1
Attachment #666811 - Attachment is obsolete: true
Attachment #667241 - Flags: review?(neil)
Comment on attachment 667241 [details] [diff] [review]
patch v1

r=me assuming Gerv is happy with it.
Attachment #667241 - Flags: review?(neil) → review+
Comment on attachment 667241 [details] [diff] [review]
patch v1

It's hard to tell from the patch, but if this is simply swapping in the official text version of the MPL 2, r=gerv.

Gerv
(In reply to Gervase Markham [:gerv] from comment #19)
> Comment on attachment 667241 [details] [diff] [review]
> patch v1
> 
> It's hard to tell from the patch, but if this is simply swapping in the
> official text version of the MPL 2, r=gerv.
> 
> Gerv

That's why I also included the "new text" (from my hg clone with the patch qpush'ed). The right half of the "diff" view of the patch comes also handy.

It is indeed a replacement of the full text of the file by the text from your comment #11.
Keywords: checkin-needed
Whiteboard: [r=Neil r=gerv cf. comment #19 and #20]
https://hg.mozilla.org/comm-central/rev/6f2f1327c1d8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.15
(In reply to Ryan VanderMeulen from comment #21)
> https://hg.mozilla.org/comm-central/rev/6f2f1327c1d8

That was fast! :-) Ryan, don't you ever sleep? ;-)
Whiteboard: [r=Neil r=gerv cf. comment #19 and #20]
I have an infant, so not much :P
You need to log in before you can comment on or make changes to this bug.