IPv6 ssl certificate not downloaded

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
6 years ago
6 years ago

People

(Reporter: Melanie.Bernkopf, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

1 connect to a IPv6 enabled Site with a certificate not matching that IP
2 Klick add exception
3 download certificate ( fail in IPv6)

Reproducable on Linux Windows MacOS

For verification also tried on google-chrome Internet Explorer ( where it worked ).
Same server with IPv4 works. 


Actual results:

nothing

E.g.: the certificate is not downloaded and can´t be seen
the same windows is shown as after klicking the add eception button ( even after several times klicking download certificate)

message shown: No Information available


Expected results:

certificate data shown 
permanent or other exception beeing addable to visit the site

Comment 1

6 years ago
please search before you file a bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633001
(Reporter)

Comment 2

6 years ago
(In reply to Jo Hermans from comment #1)
> please search before you file a bug
> 
> *** This bug has been marked as a duplicate of bug 633001 ***

I searched and this bug report you mention is different.
In the other bug the problem is in ssl itself here the certificate is accepted by ssl
but it is not added as exception.

Certificate can be validated but is not for the current ipv6 address. firefox is getting the certificate and decides as in ipv4 that the certificate doesn´t match the server then it gives the option to add an exception there firefox can´t get the certificate anymore.

in this case it is a problem in importing the certificate and not the sec_error_untrusted_issuer which comes only with self signed certificates ( no report from us after testing because we saw the bug 633001 ).
Status: RESOLVED → UNCONFIRMED
Component: Untriaged → Security
OS: Linux → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.