Incorrectly bolding text

VERIFIED FIXED in mozilla0.9.7

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Jacek Furmankiewicz, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.7
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE; 3 days;)

(Reporter)

Description

17 years ago
Build: 2001050720
In the composer "Show all tags" window I have text spread across 2 lines:
e.g.

BAND NAME "Album name" label
6 / 8

I select this entire text and press "Bold". I expect it to put one <B></B> tag
around the whole phrase, i.e. ([B] is an icon for the Bold icon in the Show All
tags view)

[B]BAND NAME "Album name" label
6 / 8

Instead it puts 3 bold tags:

[B]BAND NAME "Album name" label[B]
[B}6 / 8

This is totally unnecessary, there should only be 1 tag around the selection
(especially since in my case I want to add an attribute <b class="header"> to
properly integrate with my style sheet. In this case I would have to manually
add this attribute 3 times instead of once.

Comment 1

17 years ago
weird ... it seems that the br is triggering an indication to end the bold, then 
a bold gets wrapped around the br and then the second line gets a bold, you 
actually end up with this:
<b>Band Name "Album name" label</b><b><br>
</b><b>6 / 8</b><br>
Assignee: beppe → jfrancis
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: correctness
Priority: -- → P3
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

17 years ago
096
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.6
(Assignee)

Comment 3

17 years ago
*** Bug 89454 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Whiteboard: EDITORBASE; 3 days;
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 4

17 years ago
fixed by earlier checkin
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
Verified on build 2001112803.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.