Closed Bug 795117 Opened 9 years ago Closed 6 years ago

Visible clipping on Toroid WebGL demo

Categories

(Core :: Canvas: WebGL, defect)

17 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox16 --- unaffected
firefox17 - ---
firefox18 - ---

People

(Reporter: epinal99-bugzilla2, Assigned: jgilbert)

References

Details

(Keywords: regression, Whiteboard: webgl-correctness)

Attachments

(2 files)

Open Toroid demo: http://www.cs.cmu.edu/~rjhall/webgl/toroid_6.html
When the torus is animating, the animation clipping is visible with white pixels.
Uncheck 'Transmittance' and 'Reflectance' boxes to emphasize the issue.

Disabling HWA doesn't fix the issue.

m-c
good=2012-07-25
bad=2012-07-26
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ef20925bc2a5&tochange=20db7c6d82cc

I suspect ANGLE r1242 update (Bug 774755) or Bug 776001.
FWIW, less but still present Pixels are also visible without ANGLE 1267 using Native (webgl.prefer-native-gl;true) and they are also visible using ANGLE 1275 in Google Chrome Canary.
In local build
Last Good: e5e8d176ac96
First bad: 39c6cd95de25

Regressed by Bug 774755
Blocks: 774755
Tracking for now, but if this isn't a prevalent issue, we'll untrack for release.
Assignee: nobody → bjacob
(In reply to Alex Keybl [:akeybl] from comment #3)
> Tracking for now, but if this isn't a prevalent issue, we'll untrack for
> release.

No dupes thus far. Benoit - are you concerned that this will be a major issues with MapsGL/Games?
Sorry, I didn't realize that this bug could affect MapsGL. What is the concern here?
So as far as I can tell, all what we know is that some page used to draw what it wanted to, and doesn't anymore.

We don't know if this is a regression, or if it's that the page is incorrect and the newer ANGLE is more strict.

If we did know that it was a ANGLE regression (i.e. that the page is correct), the good next step would be to file a ANGLE bug.

I still don't see any impact for any known-correct page, or any 'famous' page like MapsGL.

No need to track this.
(In reply to Benoit Jacob [:bjacob] from comment #6)
> I still don't see any impact for any known-correct page, or any 'famous'
> page like MapsGL.

Yep - comment 4 was more of a question than a statement. Glad to hear this won't have any major user impact.
Whiteboard: webgl-correctness
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

I have tested your issue on latest FF release (45.0.2), latest Nightly build (20160421030302) and managed to reproduce it. Chrome and IE have the same white pixels on the animation.
Assignee: jacob.benoit.1 → nobody
(In reply to Paul Pasca[:PoollyMcklayn] from comment #8)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
> Build ID: 20160407164938
> 
> I have tested your issue on latest FF release (45.0.2), latest Nightly build
> (20160421030302) and managed to reproduce it. Chrome and IE have the same
> white pixels on the animation.

Please post your about:support, and a screenshot of the artifacts if you can.

I cannot reproduce on Nightly Win10 w/NV.
Assignee: nobody → jgilbert
Attached image Untitled.png
Troubleshooting Information
This page contains technical information that might be useful when you're trying to solve a problem. If you are looking for answers to common questions about Firefox, check out our support website.
Application Basics
Name 	Firefox
Version 	45.0.2
Build ID 	20160407164938
Update History 	
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0
Profile Folder 	
Enabled Plugins 	about:plugins
Build Configuration 	about:buildconfig
Memory Use 	about:memory
Registered Service Workers 	about:serviceworkers
Multiprocess Windows 	0/1 (default: false)
Safe Mode 	false
Crash Reports for the Last 3 Days
Report ID 	Submitted
bp-6d7872f0-5d4b-455a-90a4-3fbdd2160420	2 days ago

All Crash Reports
Extensions
Name 	Version 	Enabled 	ID
Adblock Plus	2.7.2	true	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Firefox Hello Beta	1.1.14	true	loop@mozilla.org
Graphics
Adapter Description	NVIDIA GeForce 210
Adapter Drivers	nvd3dum nvwgf2um,nvwgf2um
Adapter RAM	1024
Asynchronous Pan/Zoom	none
Device ID	0x0a65
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.17568)
Driver Date	8-17-2015
Driver Version	9.18.13.4181
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Supports Hardware H264 Decoding	Yes
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Important Modified Preferences
Name 	Value accessibility.typeaheadfind.flashBar	0
browser.cache.disk.capacity	358400
browser.cache.disk.filesystem_reported	1
browser.cache.disk.smart_size.first_run	false
browser.cache.disk.smart_size.use_old_max	false
browser.cache.frecency_experiment	3
browser.download.folderList	0
browser.download.importedFromSqlite	true
browser.places.smartBookmarksVersion	7
browser.search.useDBForOrder	true
browser.sessionstore.upgradeBackup.latestBuildID	20160407164938
browser.startup.homepage_override.buildID	20160407164938
browser.startup.homepage_override.mstone	45.0.2
browser.urlbar.suggest.searches	true
browser.urlbar.userMadeSearchSuggestionsChoice	true
dom.apps.reset-permissions	true
dom.mozApps.used	true
extensions.lastAppVersion	45.0.2
font.internaluseonly.changed	false
gfx.crash-guard.d3d11layers.appVersion	45.0.2
gfx.crash-guard.d3d11layers.deviceID	0x0a65
gfx.crash-guard.d3d11layers.driverVersion	9.18.13.4181
gfx.crash-guard.d3d11layers.feature-d2d	true
gfx.crash-guard.d3d11layers.feature-d3d11	true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle	true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle	true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11	false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp	false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11	true
gfx.crash-guard.status.d3d11layers	2
gfx.crash-guard.status.d3d9video	2
gfx.crash-guard.status.glcontext	2
gfx.direct3d.last_used_feature_level_idx	0
gfx.driver-init.appVersion	42.0
gfx.driver-init.deviceID	0x0a65
gfx.driver-init.driverVersion	9.18.13.4181
gfx.driver-init.feature-d2d	true
gfx.driver-init.feature-d3d11	true
gfx.driver-init.status	2
media.gmp-eme-adobe.abi	x86-msvc-x86
media.gmp-eme-adobe.lastUpdate	1453826805
media.gmp-eme-adobe.version	15
media.gmp-gmpopenh264.abi	x86-msvc-x86
media.gmp-gmpopenh264.lastUpdate	1453826806
media.gmp-gmpopenh264.version	1.5.3
media.gmp-manager.buildID	20160407164938
media.gmp-manager.lastCheck	1461307412
media.hardware-video-decoding.failed	false
media.webrtc.debug.aec_log_dir	C:\Users\PAUL~1.PAS\AppData\Local\Temp
media.webrtc.debug.log_file	C:\Users\PAUL~1.PAS\AppData\Local\Temp\WebRTC.log
media.youtube-ua.override.to	43
network.cookie.prefsMigrated	true
network.predictor.cleaned-up	true
places.database.lastMaintenance	1461229393
places.history.expiration.transient_current_max_pages	80467
plugin.disable_full_page_plugin_for_types	application/pdf
plugin.importedState	true
plugin.state.flash	0
plugin.state.npdeployjava	1
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_bgcolor	false
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_bgimages	false
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_duplex	-437918235
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_edge_bottom	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_edge_left	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_edge_right	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_edge_top	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_evenpages	true
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_footercenter	
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_footerleft	&PT
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_footerright	&D
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_headercenter	
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_headerleft	&T
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_headerright	&U
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_in_color	true
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_margin_bottom	0.5
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_margin_left	0.5
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_margin_right	0.5
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_margin_top	0.5
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_oddpages	true
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_orientation	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_page_delay	50
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_data	1
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_height	11.00
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_name	
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_size_type	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_size_unit	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_paper_width	8.50
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_resolution	-437918235
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_reversed	false
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_scaling	1.00
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_shrink_to_fit	true
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_to_file	false
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_unwriteable_margin_bottom	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_unwriteable_margin_left	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_unwriteable_margin_right	0
print.printer_\\192.168.1.13\PrinterEtaj3BM.print_unwriteable_margin_top	0
print.printer_Foxit_Reader_PDF_Printer.print_bgcolor	false
print.printer_Foxit_Reader_PDF_Printer.print_bgimages	false
print.printer_Foxit_Reader_PDF_Printer.print_duplex	-437918235
print.printer_Foxit_Reader_PDF_Printer.print_edge_bottom	0
print.printer_Foxit_Reader_PDF_Printer.print_edge_left	0
print.printer_Foxit_Reader_PDF_Printer.print_edge_right	0
print.printer_Foxit_Reader_PDF_Printer.print_edge_top	0
print.printer_Foxit_Reader_PDF_Printer.print_evenpages	true
print.printer_Foxit_Reader_PDF_Printer.print_footercenter	
print.printer_Foxit_Reader_PDF_Printer.print_footerleft	&PT
print.printer_Foxit_Reader_PDF_Printer.print_footerright	&D
print.printer_Foxit_Reader_PDF_Printer.print_headercenter	
print.printer_Foxit_Reader_PDF_Printer.print_headerleft	&T
print.printer_Foxit_Reader_PDF_Printer.print_headerright	&U
print.printer_Foxit_Reader_PDF_Printer.print_in_color	true
print.printer_Foxit_Reader_PDF_Printer.print_margin_bottom	0.5
print.printer_Foxit_Reader_PDF_Printer.print_margin_left	0.5
print.printer_Foxit_Reader_PDF_Printer.print_margin_right	0.5
print.printer_Foxit_Reader_PDF_Printer.print_margin_top	0.5
print.printer_Foxit_Reader_PDF_Printer.print_oddpages	true
print.printer_Foxit_Reader_PDF_Printer.print_orientation	0
print.printer_Foxit_Reader_PDF_Printer.print_page_delay	50
print.printer_Foxit_Reader_PDF_Printer.print_paper_data	1
print.printer_Foxit_Reader_PDF_Printer.print_paper_height	11.00
print.printer_Foxit_Reader_PDF_Printer.print_paper_name	
print.printer_Foxit_Reader_PDF_Printer.print_paper_size_type	0
print.printer_Foxit_Reader_PDF_Printer.print_paper_size_unit	0
print.printer_Foxit_Reader_PDF_Printer.print_paper_width	8.50
print.printer_Foxit_Reader_PDF_Printer.print_resolution	-437918235
print.printer_Foxit_Reader_PDF_Printer.print_reversed	false
print.printer_Foxit_Reader_PDF_Printer.print_scaling	1.00
print.printer_Foxit_Reader_PDF_Printer.print_shrink_to_fit	true
print.printer_Foxit_Reader_PDF_Printer.print_to_file	false
print.printer_Foxit_Reader_PDF_Printer.print_unwriteable_margin_bottom	0
print.printer_Foxit_Reader_PDF_Printer.print_unwriteable_margin_left	0
print.printer_Foxit_Reader_PDF_Printer.print_unwriteable_margin_right	0
print.printer_Foxit_Reader_PDF_Printer.print_unwriteable_margin_top	0
privacy.cpd.cache	false
privacy.cpd.cookies	false
privacy.cpd.downloads	false
privacy.cpd.formdata	false
privacy.cpd.history	false
privacy.sanitize.migrateClearSavedPwdsOnExit	true
privacy.sanitize.migrateFx3Prefs	true
security.disable_button.openCertManager	false
security.disable_button.openDeviceManager	false
security.sandbox.content.tempDirSuffix	{0e18ac0f-a8b0-4f5b-bbfa-fa5e1a88ba14}
services.sync.declinedEngines	
storage.vacuum.last.index	1
storage.vacuum.last.places.sqlite	1459415690
Important Locked Preferences
	Name 	Value
JavaScript
Incremental GC 	true
Accessibility
Activated 	false
Prevent Accessibility 	0
Library Versions
	Expected minimum version	Version in use
NSPR	4.12	4.12
NSS	3.21.1 Basic ECC	3.21.1 Basic ECC
NSSSMIME	3.21.1 Basic ECC	3.21.1 Basic ECC
NSSSSL	3.21.1 Basic ECC	3.21.1 Basic ECC
NSSUTIL	3.21.1	3.21.1
Experimental Features
Name 	ID 	Description 	Active 	End Date 	Homepage 	Branch
A screenshot of the issue would be nice, I don't remember how the clipping was.
I can reproduce on the bad build(17.0a1).

However, It seems improved.
 * I almost imperceptible on Beta46 and later.
 * And It is much less than Chrome51 dev.
I'm closing this unless it gets worse/is still bad.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I've tested this on the latest release(45.0.2) and latest Nightly(48.0a1). The print screen was captured from 45.0.2 release and it is still reproducible. Is better that Chrome, but still an issue in Firefox. I don't believe that we should close this, until the issue is completely gone.
You need to log in before you can comment on or make changes to this bug.