Log in user with Persona during pay flow

RESOLVED DUPLICATE of bug 805673

Status

Marketplace
Payments/Refunds
RESOLVED DUPLICATE of bug 805673
6 years ago
5 years ago

People

(Reporter: kumar, Assigned: jrconlin)

Tracking

2012-11-01
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

After the JWT has been verified (bug 795127) use navigator.id to log the user in to continue with the pay flow. The email returned from Persona may be unverified (bug 794634). Some UI might need to be shown while waiting for the Persona server.
Blocks: 794651
I think this is going to be a part of what JR is doing in bug 794634.  Throwing in our milestone so it doesn't get lost.
Assignee: nobody → jrconlin
Target Milestone: --- → 2012-11-01
Depends on: 805673
There has been some churn on how we are persisting user IDs. bug 805673 should shed light on what to do next.
This is way less complicated. Hooray! Andy's patch in bug 805673 is all we need to store and pass around user identities. Previously I thought we would need more scaffolding.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805673
You need to log in before you can comment on or make changes to this bug.