jsbridge timeout fix (for bug 656505) uses DST unsafe datetime.now() instead datetime.utcnow()

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: xabolcs, Assigned: moijes12)

Tracking

({regression})

Details

(Whiteboard: [mentor=whimboo][good first bug][lang=py])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Regarding to Bug 775057, jsbridge/jsbridge/__init__.py should use datetime.utcnow().

See comment on GitHub [1]!




[1] https://github.com/mozilla/mozmill/commit/8dd8b11d2959#commitcomment-1779089
(Reporter)

Updated

6 years ago
See Also: → bug 775057
Whiteboard: [good first bug][lang=py] → [mentor=whimboo][good first bug][lang=py]
(Assignee)

Comment 1

6 years ago
Created attachment 709008 [details] [diff] [review]
Changes made to __init__.py

After making the change, I ran ./setup_development.py and it executed. I'm still finding out how to build and execute a local development version of mozmill.
(Reporter)

Comment 2

6 years ago
Hi!

Personally I use mozmill-environment [1] to test patches for mozmill.
"run.cmd" below is mozmill-environment's start file (in Windows case).

Do you have mozmill-environment?
If not, then you could download the environment builder
from whimboo's repo which creates a zip pack for you.
To build it without mozmill I used to feed it 
with non-existent mozmill version, e.g. "master".
Extract it somewhere and run!

Now you have mozmill-env.
Then apply your patches to your files and...
... see below! :)

> 11:03 me: hi!
> 11:04 how can i set up mozmill-environment with mozmill master instead of
> mozmill-1.5.18?
>   wanna verify screenshot bug :)
> 11:05 Henrik: hey
>   that's easy
>   just execute run.cmd manually
>   cd into the mozmill source repo
>   and call ./setup_development.py
> 11:06 that will install all necessary packages
>  me: ohh, so noob question. :D
>  Henrik: :)
>   no worries
>  me: thanks!

After that, you could use "mutt" to test mozmill.

For example:
$ mutt -b /c/Program\ Files/Mozilla\ Aurora/firefox.exe
(Reporter)

Updated

6 years ago
Assignee: nobody → moijes12
Status: NEW → ASSIGNED
(Reporter)

Updated

6 years ago
Attachment #709008 - Flags: review?(hskupin)
Comment on attachment 709008 [details] [diff] [review]
Changes made to __init__.py

Review of attachment 709008 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me. Thanks for the patch! I will get it landed shortly.
Attachment #709008 - Flags: review?(hskupin) → review+
https://github.com/mozilla/mozmill/commit/38fdc19b4e41e67ba1a62337073ab1f05b010d09

If you have interests to further contribute patchs please let me know. Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

6 years ago
Yes I do. But why do you ask ? This is fixed, isn't it?
I ask because of other mentored bugs in the mozmill component and not this one.
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.