[dev] https://moztrap-dev.allizom.org/manage/suite/add/ returns 503[Service Unavailable]

VERIFIED FIXED

Status

Mozilla QA
MozTrap
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: AlinT, Assigned: camd)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 665863 [details]
Screenshot of the issue.

1.Go to https://moztrap-dev.allizom.org/manage/suite/add/

Expected results
Page should load

Actual results:
Returns 503[Service Unavailable]

*This bug was found due to failure on moztrap-tests suite (TestManageSuitesPage.test_that_user_can_create_and_delete_suite)
(Reporter)

Updated

6 years ago
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Comment 1

6 years ago
This issue has been seen when there are hundreds of test cases for the product that the suite belongs to.  I recently did a test (on moztrap-dev) with the "CamProduct" where I added 1000 cases to reproduce the error.  I have since removed most of those.  

But your test doesn't use that product, you create your own product each time.  So perhaps this is a new issue.

How frequent is this error?  every time the test executes?
(Assignee)

Updated

6 years ago
Assignee: nobody → cdawson
(Assignee)

Comment 2

6 years ago
I removed a ton of test case records from -dev and it seems to be working now.  But this is another data point for another bug, so I'm keeping this open and dependent on the other one.
Depends on: 794271
(Assignee)

Comment 3

6 years ago
I think this is fixed now.  I improved the queries used and it doesn't seem to give the error any longer.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

6 years ago
:camd You were right.
Double checked it myself and marking it QA Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.