Closed Bug 795319 Opened 7 years ago Closed 6 years ago

Bing Maps fails to load with mobile UA (Firefox Android)

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aaronmt, Assigned: karlcow, NeedInfo)

References

()

Details

(Whiteboard: [serversniff][country-all][microsoft][sitewait][lastcheck-2014-01-27])

Attachments

(1 file)

Firefox 

* Mozilla/5.0 (Android; Mobile; rv:17.0) Gecko/17.0 Firefox/17.0

Bing Maps draws an empty black screen.

iPhone

* Mozilla/5.0 (iPad; CPU OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

Bing Maps draws an initial map

Android (Galaxy Nexus)

* Mozilla/5.0 (Linux; U; Android 4.0.2; en-us; Galaxy Nexus Build/ICL53F) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30

Bing Maps draws an initial map
I recall Joe doing outreach with Bing maps a few weeks back. cc-ing him for input
Adding Joanne, who can maybe push from business side as well.
Adding also,

Firefox Tablet

* Mozilla/5.0 (Android; Tablet; rv:17.0) Gecko/17.0 Firefox/17.0 

Bing Maps draws an empty black screen.
I have sent a request to my business contact for help - I will update as soon as I have a response.  Thanks, Joanne
Emailed again today, still waiting for a contact. jn
Joanne - Do you mean that you're waiting for a technical/dev contact?

Joe - Do you know anyone working on Bing whom you can connect with Joanne?
You could try - Stephen Stchur <sstchur@microsoft.com>
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Trunk → unspecified
I've contacted the appropriate owners within the Bing Maps team and they are investigating the issue.

Regards,

Raul.
Hi Raul,

Is there any update from the team?
Touching base with Bing Maps team for an update.

Regards,

Raul
Per the repro steps above, it seems to be a miscommunication on the URL being used.

The bug says:
http://m.bing.com/maps 

The correct URL should be:
http://m.bing.com/maps/home

Please confirm this is the issue and if there are further questions I'll make sure they reach out directly.

Regards,

Raul
Hi Raul,

When I go to Bing Maps from anywhere on the web, such as Bing.com and select Maps, I am taken to http://m.bing.com/maps. That URL also takes me to a similar site with a similar issue except maps continues to fail to load, this time as a white screen instead of a black screen.

Once can reproduce this on any desktop browser by just clicking the links above.
Hi, I am from Bing maps team.  As mentioned earlier, the url is incorrect.  I will need to find out how you are getting to this URL.  

Are you testing PC link to mobile link?  If that is the case there might be some broken such as this.  
If you are typing in the URL in address bar this incorrect URL
If you are visiting www.bing.com using mobile browser you should get mobile experience which should take you to the correct URL.

Please update with step-by-step repro.

Thanks.
(In reply to hoonk from comment #13)
> Hi, I am from Bing maps team.  As mentioned earlier, the url is incorrect. 
> I will need to find out how you are getting to this URL.  

Ok ...

In order to find Bing Maps, I do what anybody else does, I search for it. I find Bing Maps by searching Google for 'Bing Maps'; the first result is 'Bing Maps'. Tapping that, I would assume would re-direct me to the 'correct' mobile version, instead I get 'http://m.bing.com/maps/?mid=10006', again no mobile redirection to 'the correct site'

Searching for 'Bing Maps' on http://m.bing.com (Mobile Bing) yields a result for Bing Maps. Tapping that first result, I get to 'http://m.bing.com/maps/?mid=1006', again no mobile redirection to 'the correct site'

> Are you testing PC link to mobile link?  If that is the case there might be
> some broken such as this.

I am using an Android device with Firefox installed on my phone and searching for 'Bing Maps' on Google and on Bing.
  
> If you are typing in the URL in address bar this incorrect URL

I am using whatever the search engine provides; it is up to Microsoft to perform the correct redirection.

> If you are visiting www.bing.com using mobile browser you should get mobile
> experience which should take you to the correct URL.

It does, but it's broken.

The second URL you posted: http://m.bing.com/maps/home, is also broken. Here is a screenshot of it broken in Firefox for Android and in Chrome for Android (http://people.mozilla.com/~atrain/mobile/bing-maps-busted.png)

> Please update with step-by-step repro.

Visit both URL's.

> Thanks.

Thanks.
(In reply to Aaron Train [:aaronmt] from comment #14)

> Ok ...
> 
> In order to find Bing Maps, I do what anybody else does, I search for it. I
> find Bing Maps by searching Google for 'Bing Maps'; the first result is
> 'Bing Maps'. Tapping that, I would assume would re-direct me to the
> 'correct' mobile version, instead I get 'http://m.bing.com/maps/?mid=10006',
> again no mobile redirection to 'the correct site'
> 
> Searching for 'Bing Maps' on http://m.bing.com (Mobile Bing) yields a result
> for Bing Maps. Tapping that first result, I get to
> 'http://m.bing.com/maps/?mid=1006', again no mobile redirection to 'the
> correct site'

> The second URL you posted: http://m.bing.com/maps/home, is also broken. Here
> is a screenshot of it broken in Firefox for Android and in Chrome for
> Android (http://people.mozilla.com/~atrain/mobile/bing-maps-busted.png)

It looks like most of the concerns would fall into PC to Mobile link since search results do not specifically provide mobile links.  We do know that there is a problem in this area.  In short term, we do not have any plan to address this issue.

However, it looks like browser issue.  As mentioned above both Android and iPhone browsers work correctly.  And our support matrix includes various versions of these mobile browsers.  It is highly likely that we do not support this browser on our premium experience.  There is no map in non-premium experience.

We will need to add this browser to our premium experience matrix.

So for now, it is expected failure.
Interestingly, when I spoof the UA in Firefox for Android to be an Android Stock UA Bing Maps is mostly useable. Seems like simply recognizing the Firefox browsers as modern mobile browsers would be a big improvement.

For reference, the Firefox UAs are documented at https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference
Yes, that should solve the problem.  I will discuss with the responsible persons and see if this can be addressed sooner than later.  Thanks.
Do we have an update here? As of today, visiting Bing Maps is still broken and the broken URL still does not redirect to a working version.
ping?
Attached image Bing Maps (July 2013)
Any update here? I've noticed now that it seems all that loads in Bing Maps is a mere text-box. 

* There is still no way for users to use Bing Maps on Firefox for Android. *
This is still broken.  The Bing experience overall in Firefox for Android is rather abysmal.
Flags: needinfo?(hoonk)
Aaron, I will reach out to the Bing Maps team to get you a resolution.
Apologies for lack of followup here.

Raul.
Thanks Raul. Please push for a fix for us :-)

Observations you can pass on:

Sending the same User-Agent header Safari on iPhone sends makes *both* the URL http://m.bing.com/maps and the URL http://m.bing.com/maps/home load fine here. The browser sniffing at the backend sends Firefox on Android a mere 3578 bytes of source code (including several style sheets that give 404 errors when requested), compared to the 508653 bytes Safari on iPhone gets.

It looks like you have intended to maintain a "lo-fi" basic map site for simplistic mobile browsers but nobody is working on it, it's broken, and some browsers that could handle the full site get the broken version. It should be very simple to fix by adjusting the backend sniffing, FYI you need to handle User-Agent strings in this format:

Mozilla/5.0 (Android; Mobile; rv:24.0) Gecko/24.0 Firefox/24.0
Mozilla/5.0 (Mobile; rv:24.0) Gecko/24.0 Firefox/24.0

but we recommend just detecting the word "Mobile" or "mobi" (case insensitive) and send mobile content. (It doesn't seem useful to send a broken site to *any* client, so unless you intend to fix and maintain a lo-fi mobile site you should just distinguish Mobile and Desktop clients IMHO).
Whiteboard: [serversniff][country-all][microsoft][sitewait]
As of today, this is still very broken.
Whiteboard: [serversniff][country-all][microsoft][sitewait] → [serversniff][country-all][microsoft][sitewait][lastcheck-2013-12-19]
Whiteboard: [serversniff][country-all][microsoft][sitewait][lastcheck-2013-12-19] → [serversniff][country-all][microsoft][sitewait][lastcheck-2014-01-27]
Contacted someone at Microsoft who is in charge of Web Compatibility issues.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Duplicate of this bug: 1000169
So there is progress on this.

I have tested on Firefox Android (released and Aurora). And it is working. Be sure to clean your cache and cookies before.

On entering http://bing.com/maps, we receive a fully fonction mobile version.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Summary: Bing Maps fails to load with mobile UA → Bing Maps fails to load with mobile UA (Firefox Android)
Blocks: 1005783
I have created a second bug for Firefox OS which is still not working. Bug 1005783
Can it be? No way. *rubs eyes* Let me try this. 

It works!
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.