select 10 ix machines to be re-imaged as w64 builders

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: hwine, Assigned: arr)

Tracking

Details

(Whiteboard: [reit] [capacity] [buildduty], URL)

(Reporter)

Description

5 years ago
With desktop builds on mock machines, we can move more of the ix boxes to windows builders. This bug will pass through many hands before done:

 - buildduty to identify & take out of production 10 ix slaves currently
   assigned to pool build-scl1
 - relops to coordinate changes with dcops
 - hwine to put new builders into production
(In reply to Hal Wine [:hwine] from comment #0)
>  - buildduty to identify & take out of production 10 ix slaves currently
>    assigned to pool build-scl1

The following slaves were disabled and marked as "decommissioned"

linux-ix-slave32
linux-ix-slave33
linux-ix-slave34
linux-ix-slave35
linux-ix-slave36
linux-ix-slave37
linux64-ix-slave18
linux64-ix-slave19
linux64-ix-slave20
linux64-ix-slave21
Moving to relops
Assignee: nobody → server-ops-releng
Component: Release Engineering: Machine Management → Server Operations: RelEng
QA Contact: armenzg → arich
Filed bug 798046 to disable nagios checks
Blocks: 798046

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/6e34c2118a92
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Looks like a (In reply to Ed Morley [:edmorley UTC+1] from comment #4)
> https://hg.mozilla.org/mozilla-central/rev/6e34c2118a92

Looks unrelated to this bug
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Duplicate of this bug: 798046
(Assignee)

Comment 7

5 years ago
Dustin: please change the switch ports for and populate DHCP for the following machines (and their management NICs) that are moving into the winbuild network in scl1:

linux-ix-slave32      w64-ix-slave111
linux-ix-slave33      w64-ix-slave112
linux-ix-slave34      w64-ix-slave113
linux-ix-slave35      w64-ix-slave114
linux-ix-slave36      w64-ix-slave115
linux-ix-slave37      w64-ix-slave116
linux64-ix-slave18    w64-ix-slave117
linux64-ix-slave19    w64-ix-slave118
linux64-ix-slave20    w64-ix-slave119
linux64-ix-slave21    w64-ix-slave120
(Assignee)

Updated

5 years ago
Assignee: server-ops-releng → arich
(Assignee)

Comment 8

5 years ago
dns, inventory, and nagios updated.  bug filed with dcops for physical labeling.
I have added these to DHCP on the Windows side
ports are changed.  DHCP is updated.  I dropped link on all the ports, and management ports are starting to come up.
Management ports are all up.
Blocks: 798460
Matt's totally going to kick this out on Sunday.
Assignee: arich → mlarrain
(Assignee)

Comment 13

5 years ago
These machines have been reimaged.
Assignee: mlarrain → arich
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(In reply to Rail Aliiev [:rail] from comment #5)
> Looks like a (In reply to Ed Morley [:edmorley UTC+1] from comment #4)
> > https://hg.mozilla.org/mozilla-central/rev/6e34c2118a92
> 
> Looks unrelated to this bug

I've just seen this by chance; this was for bug 795456.

Bugs are marked using a script when merged from inbound to mozilla-central. If people have used the wrong bug number, then unfortunately the wrong bug will get closed.

Please can you always ping me via IRC/email/CC me to the bug, if you see a miss-closure like this, since I have no other way of knowing (the script intentionally doesn't CC me since I'd then be CCed on hundreds of extra bugs per week). Thank you :-)
Blocks: 754184

Updated

5 years ago
No longer blocks: 754184
Blocks: 851573
No longer blocks: 851573

Updated

4 years ago
Blocks: 860890

Comment 15

4 years ago
arr and I discussed that these machines will need to be re-imaged since passwords and _dumbwin32proc.py got deployed since October (maybe more things).

I will set them up in bug 860890.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 16

4 years ago
These are also finished reimaging again.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.