If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot switch Languages!

VERIFIED WORKSFORME

Status

()

Core
Localization
P2
normal
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Robert Kaiser, Assigned: jbetak@netscape.com (away - not reading bugmail))

Tracking

({intl})

Trunk
mozilla0.9.2
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], verified on branch)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
"View > Languages and Web Content" does not work for me!

This is in build 2001-05-03-09 as well as in 0.9 (! this makes L10n XPIs almost
unuseable!), I'll try a newer one as soon as I have it installed.

I tried both in Linux, I'll try 0.9 on Win98 soon.

If I click any entry in that menu, the browser simply doesn't react. No box
telling me I need a restart, as we had before. After a restart, the "new"
language is not applied. I assume clicking the entry doesn't trigger the actual
swiching.

Comment 1

17 years ago
Reassigned to ftang.
Assignee: rchen → ftang

Comment 2

17 years ago
Reassign QA contact to jonrubin.
QA Contact: andreasb → jonrubin

Comment 3

17 years ago
nhotta- can you or jbetak take a look at this one ?
Assignee: ftang → nhotta

Comment 4

17 years ago
In the console,
--> strres.js: selectLocale() failed!

Reassign to jbetak.

Put nsbeta1 and cc to jaimejr@netscape.com.
Assignee: nhotta → jbetak
Keywords: intl, nsbeta1
accepting
Status: NEW → ASSIGNED

Comment 6

17 years ago
Adding vishy, german and ben to cc: list.
let's shoot for Beta1 and see, how we fare...
Target Milestone: --- → mozilla0.9.1
(Reporter)

Comment 8

17 years ago
oops, seems this would actually have been a dupe of 76006...

But as this one has keywords, a target milestone and is assigned, I'll do it the
other way round and dupe 76006 (no keywords, status = NEW, no target milestone,
only a few CCs) to this one.

BTW, I'm also seeing this on Win98, so I assume OS=All
OS: Linux → All
(Reporter)

Comment 9

17 years ago
*** Bug 76006 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Adding asa rto the cc: list.
Created attachment 34033 [details] [diff] [review]
Proposed patch #1 - cvs diff -u -w xpfe/global/resources > bug79551.txt
tao, ben:

could you please review? Seems like an easy fix...

Comment 13

17 years ago
r=nhotta
alecf:

would you be interested in another band-aid fix for Beta1?

Comment 15

17 years ago
Created attachment 34062 [details] [diff] [review]
mozilla/chrome/comm/content/communicator/selectLang.js:

Comment 16

17 years ago
ProfileManager can't select Languege and Region, too...
attached easy fix patch.

Comment 17

17 years ago
cc: ftang and nhotta.

attaching german's UI spec.

This sounds like a dupe of Bugs 65241, 65251, and 65253.

Comment 18

17 years ago
Created attachment 34074 [details]
UI Language and Content Pack Setup

Comment 19

17 years ago
sr=alecf on both patches

Comment 20

17 years ago
Is this _proposed_ language and content pack specification posted at
www.mozilla.org?  I'll say it again:  UI changes go through a public review
process.  If there are standing objections from mpt (owner of the UI Design
Component) or other UI design contributors then those concerns must be addressed
before the proposal becomes a specification.  An implementation will not be
checked in until the design issue is settled.

Comment 21

17 years ago
asa: the patches fix bugs, and do not change ui - they make existing ui work as
expected

Comment 22

17 years ago
r=nhotta for both patches
Jaime,

as alecf pointed out, this is not really related to bug 65241, bug 65251 or bug 
65253. This is a regression and only addresses broken functionality.

Comment 24

17 years ago
agreed . . . i can see that now. guess, its not a dupe, but related. couldn't
really tell until i had an engineer look at the attached patch.
alright then - I just checked in. Thanks everyone! 

Tsukasa:

thank you very much for pointing out the problems in the ProfileManager and 
also for your patch!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 26

17 years ago
Still have a problem for Region (ContentLocale), I could
set "ja-JP" but could not set "JP" region from profileManager.

I've filed this as bug 84443 against ChromeRegistry. Please evaluate.

Comment 27

17 years ago
Jon - Can you take a look at this one? Reopening for now and setting to M0.9.2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 28

17 years ago
katakai- jbetak is on vacation untill next wed

Comment 29

17 years ago
mark it as P2. 
Priority: -- → P2

Comment 30

17 years ago
pdt+ base on 6/11 pdt meeting.

Updated

17 years ago
Whiteboard: [PDT+]
Jon:

any news on this? I have trouble reproducing the problem Katakai is pointing 
out. I also believe that he is going to address any remaining issues in his 
code rework for bug 80230. Any reason to keep this open for 0.9.2? KaiRo, can 
we close this?

Comment 32

17 years ago
Juraj - I'm also having trouble reproducing this one.

Katakai - Could you please provide a test case for this? 
I'll attempt to reach Katakai on 06/14/2001 by phone to solicit more input.
marking dependency on bug 80230. Unless we get additional information from 
Katakai, this bug will be closed on 06/15/2001. I'll try to call him again.

Katakai? Are you reading this?
Depends on: 80230
I'm closing this. The original problem has been resolved and the Profile 
Manager glitch reported by Katakai is non-reproducable as of 06/16/2001.

Please file a new bug against the Profile Manager if needed, and have a look at 
Katakai's rework of the underlying backend in bug 80230.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 36

16 years ago
Waiting on new content and lang packs to verify this.  See bug 89531 and bug
90279 for more info.  This has basically been verified on WinMe-Ja using a tweak
to the packs that "updates" them; using that tweak, I was able to switch
language and region on the 07-10-branch build.  On Linux and Mac, Profile
Manager does not display correctly (only "Manage Profiles" button appears, and
old profiles do not appear in the window) if I download and apply an old
lang/region pack.  Investigating whether this is due to incompatibility with the
outdated pack as a result of the fix to bug 86807.

Comment 37

16 years ago
Verified on WinMe-Ja using US Win 07-18-05-branch build and ja-JP pack from JA
Win 07-17-05-branch build.  Cannot change language using same pack in
07-18-06-trunk build.  Tao, is that because the version of the trunk is different?

Filed Bugscape 7607 for problem with how ja-JP pack appears in View menu after
download.
Whiteboard: [PDT+] → [PDT+], verified on branch

Comment 38

16 years ago
right. You can't use branch packs for trunk builds.

Updated

16 years ago
Keywords: vtrunk

Comment 39

16 years ago
mass change, switching qa contact from jonrubin to ruixu.
QA Contact: jonrubin → ruixu

Comment 40

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.