Firefox won't resolve DNS correctly in certain circumstanses

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: grzech, Unassigned)

Tracking

15 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Steps to reproduce:
1) start a computer that has PPP connection to Internet.
2) Open the Firefox
3) While not being connected to the Internet try to type any url for example "www.google.com". As expected. Firefox will display the information it can't connect
4) Connect to the Internet.
5) Try to connect to the url you previously tried to reach while being unconnected (i.e. www.google.com in this example)


Actual results:

Firefox is trying to connec and it takes an infinite amount of time. It never connects and the "connecting icon" keeps spinning forever. (Note that closing all instances of Firefox and restarting it will result in correct resolving of the url and successfull connection)


Expected results:

Firefox should connect to the entered url and display the page.
(Reporter)

Updated

6 years ago
Severity: normal → major
(Reporter)

Comment 1

6 years ago
Additional notes:

Although I observed this on a computer that uses Point-to-Point Protocol to connect to Internet I suspect same will happen on a machine with any type of dynamic connection that can be disconnected and then reconnected programatically.

I first observed this behaviour on Firefox 14.0. Version 12.0 did not exhibit that behaviour.

Comment 2

6 years ago
Thanks for the report.

This is probably a duplicate of a bug like bug 512969 (there are old ones like bug 233426 too; there is also at least one about SOCKS proxy: bug 790321).
Component: Untriaged → Networking
Product: Firefox → Core
Whiteboard: DUPEME?
(Reporter)

Comment 3

6 years ago
(In reply to Aleksej [:Aleksej] from comment #2)
> Thanks for the report.
> 
> This is probably a duplicate of a bug like bug 512969 (there are old ones
> like bug 233426 too; there is also at least one about SOCKS proxy: bug
> 790321).

I'm not sure about that as bug 512969 and bug 233426 are old and this bug was not present in FF 12.0 (not sure 13.0). As for SOCKS proxy bug 790321 - I don't think it's a duplicate either, because toggling "Work Offline" off/on doesn't help me. The only way to make FF connect to a domain I tried to connect while being disconnected from Internet is to exit or kill all instances of Firefox and restart it again.
(Reporter)

Comment 4

6 years ago
It turns out this odd behaviour was caused by some extension or plugin. Can't find which one but after disabling all it worked ok. After re-enabling all basic extensions and plugins it still works correct now. Anyway, whatever it was, probably not Firefox issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.