Closed Bug 795630 Opened 8 years ago Closed 8 years ago

CapturePickerUI has an exception on Metro browser startup

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 22

People

(Reporter: bbondy, Assigned: jimm)

References

Details

Attachments

(1 file)

CapturePickerUI has an exception on Metro browser startup
/browser/metro/base/content/browser-ui.js

  try {
    1.22          // XXX This is currently failing
    1.23 +        CapturePickerUI.init();
    1.24 +      } catch(ex) {
    1.25 +        Util.dumpLn("Exception in CapturePickerUI:", ex.message);
    1.26 +      }
    1.27 +

I'm  not sure what this is for, but please mark as metro-preview if it is important.
(In reply to Jim Mathies [:jimm] from bug 795629 comment #3)
> I think this was used for screen captures on mobile devices. I think it'd be
> safe to remove CapturePickerUI.js, CaputureDialog.js, and
> chrome://browser/content/prompt/CaptureDialog.xul completely.
Product: Firefox → Firefox for Metro
Duplicate of this bug: 799255
Duplicate of this bug: 833306
This code is actually used by form upload controls; it lets the user upload a photo or video directly from the camera instead of from the filesystem.

It looks like this is no longer implemented anywhere except in Metro code, so it should be safe to remove.  (I guess it's been superceded by getUserMedia?)
http://mxr.mozilla.org/mozilla-central/ident?i=nsICapturePicker

If so, we should also file a bug to remove the code from /layout/forms.
Attached patch patchSplinter Review
Assignee: nobody → jmathies
Comment on attachment 727610 [details] [diff] [review]
patch

remove capture picker related code.
Attachment #727610 - Flags: review?(mbrubeck)
Attachment #727610 - Flags: review?(mbrubeck) → review+
Blocks: 853475
https://hg.mozilla.org/mozilla-central/rev/6adc6990dd8a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Blocks: 868428
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.