style height set to exp format

RESOLVED DUPLICATE of bug 373875

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 373875
6 years ago
6 years ago

People

(Reporter: user266266, Unassigned)

Tracking

15 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Set style height some element:
var el = document.getElementById('myel');
el.style.height = '21000021px';

if set el.style.height = '21000021px', result: style.height = '2.1e+7px'


Actual results:

result set to exp format:

el.style.height == '2.1e+7px';



Expected results:

el.style.height == '21000021px';
Created attachment 666344 [details]
simple testcase
I can confirm that Firefox15.0.1 and Seamonkey trunk respond with "2.1e+7px" while IE9 and Opera12 respond with "21000021px".

I guess that this is a dupe but I don't know good terms to search....
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: CSS Object Model
Ever confirmed: true
Product: Firefox → Core
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373875
You need to log in before you can comment on or make changes to this bug.