Selecting multiple PGP/MIME encrypted messages crashes Thunderbird

RESOLVED FIXED in Thunderbird 18.0

Status

MailNews Core
MIME
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Patrick Brunschwig, Assigned: Patrick Brunschwig)

Tracking

Thunderbird 18.0

Thunderbird Tracking Flags

(thunderbird16 fixed, thunderbird17 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 666322 [details] [diff] [review]
Patch v1

The implementation of nsPgpMimeProxy.cpp assumes that there is only 1 instance of nsIPgpMimeProxy (and its corresponding JS object). However, this assumption is wrong, as can be shown by selecting multiple PGP/MIME messages.

The result is that Thunderbird crashes on all platforms if the JS Object is registered. The attached patch changes the single instance (service) type of nsIPgpMimeProxy to an object that is created individually for each message.
(Assignee)

Updated

5 years ago
Attachment #666322 - Flags: review?(mbanner)
(Assignee)

Updated

5 years ago
Blocks: 768928
Comment on attachment 666322 [details] [diff] [review]
Patch v1

If you need this on TB 16, please request approval-comm-aurora and approval-comm-beta later today as we're likely to build the final beta today.
Attachment #666322 - Flags: review?(mbanner) → review+
Keywords: checkin-needed
(Assignee)

Comment 2

5 years ago
Comment on attachment 666322 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Regression caused by (bug #): 768928
User impact if declined: crashes Thunderbird if Enigmail installed
Testing completed (on c-c, etc.): comm-central, comm-aurora
Risk to taking this patch (and alternatives if risky): risk is low, changes are straight forward and have no side impact.
Attachment #666322 - Flags: approval-comm-beta?
Attachment #666322 - Flags: approval-comm-aurora?
Checked in: https://hg.mozilla.org/comm-central/rev/3cb6fce9232d
Assignee: nobody → patrick
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0
Attachment #666322 - Flags: approval-comm-beta?
Attachment #666322 - Flags: approval-comm-beta+
Attachment #666322 - Flags: approval-comm-aurora?
Attachment #666322 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/1c32536d12f3
https://hg.mozilla.org/releases/comm-beta/rev/e53b1c5df7f1
status-thunderbird16: --- → fixed
status-thunderbird17: --- → fixed
You need to log in before you can comment on or make changes to this bug.