Closed Bug 795713 Opened 7 years ago Closed 4 years ago

Submit Firefox for inclusion in the Windows Store

Categories

(Marketing :: General, task, P4)

Unspecified
Windows 10

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jimm, Assigned: clarkbw)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [FXGrowth])

Attachments

(6 files)

http://blogs.msdn.com/b/windowsstore/archive/2012/06/08/listing-your-desktop-app-in-the-store.aspx

A current search for 'firefox' returns zero results.

Also there's a rather detailed legal agreement during sign-up that legal should probably look over.
Whiteboard: [metro-mvp?]
Assignee: nobody → asa
Whiteboard: [metro-mvp?] → [preview-triage]
Attached image Overview (top)
Attached image Overview (bottom)
Attached image Details
Attached image Example Reviews Section
-> Over to Kar
Assignee: asa → krudnitski
Windows 8 has:
- Desktop apps
- Metro apps
- New Experienced Enabled Desktop Browsers [What we are]

The store can list:
- Desktop apps
- Metro apps 

We won't be listed as a Metro app, we don't go through the store for updates and installs. And we aren't a Metro app.  It's not an option.

Desktop apps I believe just link you to a download to get the Desktop app.

We should be ultra-clear on our Windows store Desktop app page messaging, to advertise the fact that what the user is downloading, is both a Metro application and a Desktop application.
Otherwise the user will just think they're getting the Desktop application that we are being listed under.
We may also want to be careful about being listed before Metro Firefox comes out. It could lead to negative ratings based on not having the Metro Firefox front end available.
OS: Windows 8 → Windows 8.1
Whiteboard: [preview-triage]
Blocks: metrobacklog
Whiteboard: [feature] p=0
Note on our store presence - I was testing a store related bug and noticed that the main screen shot window is scrollable for chrome, with multiple screen shots of the browser doing different things. We should do the same.
Priority: -- → P4
Whiteboard: [feature] p=0 → p=0
This was originally being held up by metro, but now that that project is dead, should we finish this up and list fx as a desktop app in the store? Currently the only mainstream browser listed is Chrome so it gets top listing in searches for terms like "internet browser".
No longer blocks: metrobacklog
Flags: needinfo?(johnath)
Whiteboard: p=0
Switching the nag from me to Eric Petitt, who owns product marketing for Firefox
Flags: needinfo?(johnath) → needinfo?(epetitt)
Punting over to Chad as another distribution mechanism for firefox desktop
Flags: needinfo?(cweiner)
Duplicate of this bug: 1163607
Blocks: windows-10
Two questions:

1) Do we know what needs to change in Firefox to be listed in the store? Presumably this isn't as simple as handing them our existing installer?

2) Do we have any data on how many users use/expect apps in the MS app store? In other words, how much opportunity are we actually losing by not being listed in the store?
Flags: needinfo?(epetitt)
(In reply to Justin Dolske [:Dolske] from comment #13)
> Two questions:
> 
> 1) Do we know what needs to change in Firefox to be listed in the store?
> Presumably this isn't as simple as handing them our existing installer?

I think most of the work is in listing design. In the windows 8 store they provide users with a download link which the vendor specifies. We could provide our download landing page.

> 2) Do we have any data on how many users use/expect apps in the MS app
> store? In other words, how much opportunity are we actually losing by not
> being listed in the store?

I have no data on this.
Whiteboard: [FXGrowth]
(In reply to Justin Dolske [:Dolske] from comment #13)
> Two questions:
> 
> 1) Do we know what needs to change in Firefox to be listed in the store?
> Presumably this isn't as simple as handing them our existing installer?
> 
> 2) Do we have any data on how many users use/expect apps in the MS app
> store? In other words, how much opportunity are we actually losing by not
> being listed in the store?

Are Mozilla still planning to publish to the store as a Windows 8 style desktop app, or have the plans changed to use the new Project Centennial[1]? (Which would have Firefox published on and downloaded from the Store as an actual app that's been sandboxed in an App-V like environment. It would also give access to the WinRT APIs.)

[1] http://channel9.msdn.com/Events/Build/2015/2-692
Blocks: 1191384
Assignee: krudnitski → clarkbw
Flags: needinfo?(cweiner)
OS: Windows 8.1 → Windows 10
Hardware: x86_64 → Unspecified
Status update.  The Company Name "Mozilla" and Application Name: "Firefox" have both been reserved in the Windows Store and we don't know who has reserved them.  Checking within Mozilla it doesn't seem that any employees hold the reservation and MS policies forbid them from revealing the account that has the reservation.  I've filed a complaint with Microsoft using their formal process to claim trademarks.  

It has been a number since the original filing and I haven't heard back from MS after initially getting a request for additional information a week after filing.  Recently we've made some progress through a MS contact which may get things moving forward faster outside the formal process.  I'll update here as things progress.
Summary: Submit Firefox for inclusion in the (win8) Windows Store → Submit Firefox for inclusion in the Windows Store
Any update here Bryan?
Flags: needinfo?(clarkbw)
Last week we sent off another email to contacts we have in MS regarding this.  Haven't heard back yet.  I sent another message today looking for a status update.  I'll try to come back to this tomorrow if I hear anything else.
Flags: needinfo?(clarkbw)
We have cleared the trademark squatting issue.  Windows Store upload process is now in our control.  Details of submission are pending messaging review.  Justin can be on point while Byran is out.
I'm still blocked on Microsoft accounts -- the link in comment 0 (which, sadly, appears to be the only documentation on how to get listed in the Store) says the first step is to "Sign up for a Hardware/Desktop Dashboard Company Account." I've done that, it says our company approver need to approve it. That person is Ann Ignacio, she got the email shortly after I did this on Wednesday and approved it, but the Microsoft site still reports "Your user account is pending approval by your company's administrator." So.... ¯\(°_o)/¯

Bryan currently has access to the "Sign up as a company for a Windows Store developer account, using the same account as in step 1." through his own account. There appears to be no mechanism to add other people to this; feels like they're targeting single-developer shops. So we'll ultimately need to figure out how to deal with access here -- transfer it to someone in release management (Sylvestre), or some kind of generic account if that's a giant pain to do.
Attached file Appcert results (XML)
I did, however, make progress with getting the required Windows App Certification Kit results. We "pass with warnings", and they seem minor. I have no idea how strict Microsoft is about warnings, but hopefully it's enough to at least submit and see the next step in the process (which is utterly opaque).

I found the certification process confusing, because it's underdocumented, but here's what got results. It took 5-10 minutes to complete on my low-end Surface Pro. You don't need a mozilla build environment. Just the tool and a Firefox installer.

1) Install the Cert Kit from https://dev.windows.com/en-us/develop/app-certification-kit

2) Uninstall any existing Firefox, Dev Edition, Nightly, or Beta. And reboot, Just To Be Sure™.

3) Run it via Start -> apps -> "Windows Kits" -> “Windows App Cert Kit"
   …select “Validate Desktop App" from the first screen
   …for “setup file” select the Firefox installer .exe (downloaded from our website)
   …leave “command line” blank
   …for “Application Usage Type” select “per machine"

4) After a minute or so, it launches our installer. Ignore the tools warning to "do not interact with the app". You'll need to get the installer to finish -- just do a standard install, and uncheck the "launch Firefox now" checkbox at the end

5) After 2-3 more minutes, it starts progressing with the rest of the tests and launches Firefox.
  …wait ~20 seconds, and it will be closed automatically.

6) After a bit the Firefox uninstaller launches. Again, you'll need to interact with it to complete it.

7) After a bit you'll get a Save As dialog to save the results in XML form.

8) Then you'll get a page saying "Validation complete / Multiple apps installed during validation" and asking you to select one. You want Firefox, not the Mozilla Maintenance Service.

9) Final report page, says "Passed with warnings" with a link to a local HTML page that explains the results.


Couple of notes for the future:

* The App Certification Kit has a commandline version, so this might be something that can be automated. I'm unclear if we need to repeat this process after the initial submission or not, it's unclear how this all ultimately works.

* If we did want to fully automate this, we'd probably want an installer flag (unless there's already one?) to run without user interaction.

* In step 5, and automated environment would need a clean profile, and probably needs to suppress the "you are closing multiple tabs" warning that happens due to first-run pages.
Attached file Appcert results (HTML)
Here's the readable HTML results.

rstrong: any of this covered by existing bugs, or sound like real issues we should fix independent of this bug? 

Summary/spoilers:

1) Clean reversible install test
Some complaints about version numbers / install location registry entries.

2) Install to the correct folders test
"Program Mozilla Maintenance Service fails due to missing install location."
(I'd guess this is a side-effect of #1)

3) Digitally signed file test
"Mozilla Maintenance Service\Uninstall.exe does not have a valid signature"

4) Adhere to system restart manager messages
The maintenance service apparently triggered something here. 

5) Windows security features test
Looks to be mostly wanting extra compile flags for our uninstaller helpers?
Flags: needinfo?(robert.strong.bugs)
Also, I'll note that Microsoft's docs on this whole process are utterly terrible. It certainly doesn't help that, apparently, desktop apps were originally part of the Windows Store, then removed, then added back. I'm actually uncertain of the current status. Some press articles say desktop apps can be listed in the store now, but Microsoft pages say they can't...

"Desktop apps are coming to the Windows Store"
http://www.engadget.com/2015/04/29/desktop-apps-are-coming-to-the-windows-store/
"Build 2015: Microsoft Will Allow Desktop Applications in Windows Store"
https://www.thurrott.com/windows/windows-10/3210/build-2015-microsoft-will-allow-desktop-applications-in-windows-store

vs

"Action Recommended: Desktop app listings no longer supported"
http://blogs.windows.com/buildingapps/2015/05/01/get-ready-for-the-unified-dev-center-dashboard-preview-and-upcoming-store-changes/
"Important: Desktop application listings are not a part of the Windows 10 Dev Center and Windows 10 Store experiences. Existing Desktop application listings will not be discoverable in the Windows Store on Windows 10, but will remain available for Windows 8 and 8.1 users."
https://msdn.microsoft.com/en-us/windows/desktop/jj134964


In particular, I'll note that Chrome, which screenshots in this bug indicate was previously listed in the Store, is no longer listed when I search for it on my Windows 10 system.
(In reply to Justin Dolske [:Dolske] from comment #22)
> Created attachment 8663218 [details]
> Appcert results (HTML)
> 
> Here's the readable HTML results.
> 
> rstrong: any of this covered by existing bugs, or sound like real issues we
> should fix independent of this bug? 
Nothing I saw.

> Summary/spoilers:
> 
> 1) Clean reversible install test
> Some complaints about version numbers / install location registry entries.
With how we allow installing as non admin and how the user's rights can increase or decrease keeping this info in the registry up to date will be a PITA. The install location for the maintenance service is trivial.

> 2) Install to the correct folders test
> "Program Mozilla Maintenance Service fails due to missing install location."
> (I'd guess this is a side-effect of #1)
Likely

> 3) Digitally signed file test
> "Mozilla Maintenance Service\Uninstall.exe does not have a valid signature"
It is generated dynamically at install time. We could generate it during build and sign it or use the maintenance service itself to perform the uninstall.

> 4) Adhere to system restart manager messages
> The maintenance service apparently triggered something here. 
That's weird. The service is only on demand and we want to give it a chance to finish before exiting. Might be due to something missing from the service implementation that the analyzer expects to see.

> 
> 5) Windows security features test
> Looks to be mostly wanting extra compile flags for our uninstaller helpers?
as well as freebl3.dll and D3DCompiler_43.dll
To deal with this I'd prefer moving away from NSIS and going with MSI since that would solve serious issues as well. The effort to do this is non-trivial.
Flags: needinfo?(robert.strong.bugs)
In the news today: 

https://www.thurrott.com/xbox/64259/tomb-raider-rises-on-pc-as-the-first-ever-aaa-title-in-windows-store
http://www.winbeta.org/news/rise-tomb-raider-now-available-windows-store-universal-windows-10-app

Apparently this was initially touted as the first win32 app in the store, but turns out it's actually a Universal app. Which furthers my suspicion that, despite having made some confusing rumblings about it, Microsoft currently doesn't allow win32 apps into the store.

In any case, I think this bug is effectively wontfix at this point, because Microsoft's docs and process for getting into the store are so terribly opaque that I'm not sure how we could even attempt to proceed. And given the cost/benefit ratio of this work, I don't see us prioritizing this any time soon.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Depends on: 1162562
Duplicate of this bug: 1373382
Depends on: 1407734
Since Windows S [https://www.microsoft.com/en-us/windows/windows-10-s] is now introduced by Microsoft.
Maybe it's time to reconsider adding Firefox to the Windows Store?
Probably Miscrosoft will now actively promote the store and will assist developers in migrating their apps to it.
Having it at least like the firefox for IOS (ontop of OS specific engines), could be handy for those users who actively use firefox sync, readMode and don't won't to use other sync solutions.

This should be re-evaluated. Microsoft is much more open to allowing third-party apps and non-EdgeHTML programs than before.

See Also: → 1549103

(In reply to jebeld17 from comment #29)

This should be re-evaluated. Microsoft is much more open to allowing third-party apps and non-EdgeHTML programs than before.

Source? Microsoft Store Policies still disallows non-EdgeHTML web browsers.
https://docs.microsoft.com/en-us/legal/windows/agreements/store-policies#102-security

10.2.1
Products that browse the web must use the appropriate HTML and JavaScript engines provided by the Windows Platform.

This isn't enforced. Facebook, iTunes, and other Microsoft-certified Microsoft Store programs rely strictly on WebKit.

(In reply to Masatoshi Kimura [:emk] from comment #31)

(In reply to jebeld17 from comment #29)

This should be re-evaluated. Microsoft is much more open to allowing third-party apps and non-EdgeHTML programs than before.

Source? Microsoft Store Policies still disallows non-EdgeHTML web browsers.
https://docs.microsoft.com/en-us/legal/windows/agreements/store-policies#102-security

10.2.1
Products that browse the web must use the appropriate HTML and JavaScript engines provided by the Windows Platform.

You need to log in before you can comment on or make changes to this bug.