The default bug view has changed. See this FAQ.

please disable pgo on win64 builds

VERIFIED FIXED

Status

Release Engineering
Other
P1
blocker
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: akeybl, Assigned: nthomas)

Tracking

({crash, regression, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
please disable pgo on win64 builds due to bug 795594. Once resolved and respun, we can re-enable updates.

+++ This bug was initially created as a clone of Bug #795594 +++

64-bit Nightly crashes on startup. It's #1 top crasher with about 1000 crashes an hour.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=895f66c4eada&tochange=c09a0c022b2e
It's likely a regression from bug 539356 part 9f.
Updates should be stopped if you don't want to lose every users with 64-bit builds.

Signature 	mozilla::layers::LayerPropertiesBase::LayerPropertiesBase(mozilla::layers::Layer*) More Reports Search
UUID	926f65f3-3cde-4026-aac9-43e8d2120929
Date Processed	2012-09-29 14:00:20
Uptime	0
Last Crash	16 seconds before submission
Install Age	31 seconds since version was first installed.
Install Time	2012-09-29 13:59:38
Product	Firefox
Version	18.0a1
Build ID	20120929030624
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	amd64
Build Architecture Info	family 6 model 23 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x05e2, AdapterSubsysID: 2ae2107d, AdapterDriverVersion: 8.17.13.142
Processor Notes 	WARNING: JSON file missing Add-ons
EMCheckCompatibility	True
Adapter Vendor ID	0x10de
Adapter Device ID	0x05e2
Total Virtual Memory	8796092891136
Available Virtual Memory	8795830296576
System Memory Use Percentage	36
Available Page File	6873792512
Available Physical Memory	2731728896

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::layers::LayerPropertiesBase::LayerPropertiesBase 	gfx/layers/LayerTreeInvalidation.cpp:71
1 	xul.dll 	mozilla::layers::CloneLayerTreePropertiesInternal 	gfx/layers/LayerTreeInvalidation.cpp:284
2 	xul.dll 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:1029
3 	xul.dll 	nsRegion::And 	gfx/src/nsRegion.cpp:731
4 	xul.dll 	nsDisplayText::GetBounds 	layout/generic/nsTextFrameThebes.cpp:4509
5 	xul.dll 	nsDisplayList::GetBounds 	layout/base/nsDisplayList.cpp:828
6 	xul.dll 	nsRegion::SetToElements 	gfx/src/nsRegion.cpp:296
7 	xul.dll 	mozilla::FramePropertyTable::Get 	layout/base/FramePropertyTable.cpp:74
8 	xul.dll 	nsDisplayList::PaintRoot 	layout/base/nsDisplayList.cpp:957
9 	xul.dll 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1743

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3ALayerPropertiesBase%3A%3ALayerPropertiesBase%28mozilla%3A%3Alayers%3A%3ALayer*%29
(Assignee)

Comment 1

5 years ago
Aside, do tier 2 platforms really begat blocker bugs ??
Assignee: nobody → nthomas
Priority: -- → P1
(Assignee)

Comment 2

5 years ago
Created attachment 666396 [details] [diff] [review]
[buildbot-configs] disable win64 PGO

This removes builders like this
  WINNT 6.1 x86-64 mozilla-inbound pgo-build
except for try, and modifies builders like 
  WINNT 6.1 x86-64 mozilla-central nightly
to
* not have 'MOZ_PGO=1' in the client.mk compile call  (ie disable pgo)
* sendchange with branch build-system-win64-talos instead of build-system-win64-pgo-talos, same for s/talos/unittest/
Attachment #666396 - Flags: review?(bugspam.Callek)

Updated

5 years ago
Attachment #666396 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 666396 [details] [diff] [review]
[buildbot-configs] disable win64 PGO

http://hg.mozilla.org/build/buildbot-configs/rev/b86b6b0dfe05

I'll reconfig the masters and get a m-c win64 nightly running.
Attachment #666396 - Flags: checked-in+
(Assignee)

Comment 4

5 years ago
A m-c nightly with PGO disabled is now out at http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/09/2012-09-30-18-33-50-mozilla-central/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
It works for me.
Status: RESOLVED → VERIFIED

Comment 6

5 years ago
Can corroborate -> WFM, too. Win7 Professional x64, SP1

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120930183350 CSet: 31ae286fff78

If it's of any interest, it recognized my very old profile, which includes the following extensions, just fine. Everything works. 

Abduction! 3.0.14
Adblock Plus 2.1.3a.3551
Adblock Plus Pop-up Addon 0.4
Add Bookmark Here ² 13.0.20120505
Add-on Compatibility Reporter 1.1
Beef Taco (Targeted Advertising Cookie Opt-Out) 1.3.7
BetterPrivacy 1.68
Bitdefender QuickScan 0.9.9.119 [DISABLED]
Cleanest Addon Manager 6.0
Cookie Button 0.9.3
Custom Toolbar Buttons 0.6.0.8
Default 18.0a1 [DISABLED]
Download YouTube Videos as MP4 and FLV 1.4.7
DownThemAll! 2.0.15
Element Hiding Helper for Adblock Plus 1.2.3
Fasterfox Lite 3.9.9Lite
FireFTP 2.0.7
Flashblock 1.5.15.1
FlashGot 1.4.8.2
German Dictionary 2.0.2
IE Tab 2 (FF 3.6+) 4.1.3.1
JS Switch 0.2.9
keyconfig 20110522
Nightly Tester Tools 3.4pre
NoScript 2.5.6
Open link in... 1.9
OptimizeGoogle 0.79.1
Print It! 0.6.0
Quick Locale Switcher 1.7.8
QuickPageZoom 1.6.3
Red Cats (green flavor) 5.6.0 beta 3
Remove It Permanently 1.0.6.10
Restart Firefox 0.5
Shockwave Flash 11.5.500.80
Site Favicon in Urlbar 5.5
Site Identity Button Colors 0.7
SmoothWheel (AMO) 0.45.6.20100202.1
Status-4-Evar 2012.07.08.17
United States English Spellchecker 6.0
Depends on: 801386
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.