Closed Bug 795754 Opened 8 years ago Closed 8 years ago

Breakpad didn't catch crash but OS X did

Categories

(Toolkit :: Crash Reporting, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 717758

People

(Reporter: Dolske, Unassigned)

Details

Current Nightly (http://hg.mozilla.org/mozilla-central/rev/a680fd777c3b), known to be a bit crash due to DLBI I think. I crashed, got no crash reporter, but the OS X system crash reporter did catch it:


Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
pure virtual method called
abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8a263212 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff88436b34 pthread_kill + 90
2   libsystem_c.dylib             	0x00007fff8847adfa abort + 143
3   libc++abi.dylib               	0x00007fff866ccf87 abort_message + 257
4   libc++abi.dylib               	0x00007fff866caa00 __cxa_pure_virtual + 18
5   XUL                           	0x000000010219adbc mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms(gfx3DMatrix const&) + 1436
6   XUL                           	0x000000010219adbc mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms(gfx3DMatrix const&) + 1436
7   XUL                           	0x00000001021ac249 mozilla::layers::LayerManagerOGL::EndTransaction(void (*)(mozilla::layers::ThebesLayer*, gfxContext*, nsIntRegion const&, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) + 89
...

Full report: http://pastebin.mozilla.org/1851884

Seems like if the system can catch it we should too?
(Bug 795728 is for the crash itself, it seems)
Turns out this is exactly bug 717758.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 717758
You need to log in before you can comment on or make changes to this bug.