Click to call does not work

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
2 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120929191424

Steps to reproduce:

Clicked http://www.m.evanscycles.com/call/+441293574900 on this site: http://www.m.evanscycles.com/


Actual results:

Pop up appears saying "The link needs to be opened with an application." but dialer is not launched.


Expected results:

Dialer should launch.
I believe the only way to get the dialer to prompt is if the site is using the tel: intent URI/sheme in their links, and we might be abiding by that only, same with Chrome.

http://developer.android.com/guide/appendix/g-app-intents.html

The code on the site is using: <a href="/call/+441293574900">, it seems to work fine in the stock browser but fails in Chrome.

Wes/Mark, thoughts?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

6 years ago
By the way, it works on the stock AOSP browser on CM7.
(Reporter)

Comment 4

6 years ago
Hi,

any update on this?

Thanks
I'm not sure what's expected. That's a valid url. We try to open it. The stock browser on my phone (an S3) actually does the same thing.

I can't find any telephone numbers that are linked on the web site you posted. There is one that isn't linked. We can/may/should look into automatically creating links for those somehow (see bug 566225, although I have some other ideas on how to fix that if someone is interested in grabbing that). I'll mark that as a mentor bug.
(Reporter)

Comment 6

6 years ago
On my device the stock browser launches the dialer with the correct number, ready to be dialed.

The URL is "http://www.m.evanscycles.com/call/+441293574900" and the number is +441293574900.

On Firefox all I get is the message "The link needs to be opened with an application." but the dialer is not launched.
What phone? Sounds like a bug in the stock browser then. They're not obeying IETF rules for what is a url.

They're not even sending the url to the phone dialer (i.e. it doesn't show up as a handler for that url for me). They're parsing the number out and sending it. 

I'm closing this as invalid because I don't think we can do this without breaking the web. I sent a message to the website detailing the bug and how to fix it. AFAICT, this is not a defacto standard and its not a real standard, and I don't think we should encourage its use on the web. The correct way to include a link to a telephone number is to use the tel protocol. i.e. tel:+441293574900
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.